Bug 1303857 - Incorrect output when running: cinder --os-volume-api-version 1 list --limit 0
Incorrect output when running: cinder --os-volume-api-version 1 list --limit 0
Status: CLOSED DUPLICATE of bug 1303858
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
8.0 (Liberty)
x86_64 Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Eric Harney
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 04:18 EST by lkuchlan
Modified: 2016-04-26 21:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 10:03:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lkuchlan 2016-02-02 04:18:43 EST
Description of problem:
Running cinder list when limit parameter is 0, displays the full list of volumes.
The issue is on api version 1, on api version 2 it works well   


Version-Release number of selected component (if applicable):
python-cinderclient-1.4.0-1.el7ost.noarch
python-cinder-7.0.1-5.el7ost.noarch
openstack-cinder-7.0.1-5.el7ost.noarch
python-cinderclient-1.4.0-1.el7ost.noarch

How reproducible:
100%


Steps to Reproduce:
1. Create several volumes
2. Run -> cinder --os-volume-api-version 1 list --limit 0


Actual results:
All volumes from list are displayed  

[stack@instack ~]$ cinder --os-volume-api-version 1 list --limit 0
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
| 0df1795c-4afb-46be-af05-c0d7deac4446 | available |      -       |  1   |      -      |  false   |             |
| 2bc3e83a-0274-447f-8172-66d0c8ac2858 | available |      -       |  1   |      -      |  false   |             |
| d0332391-2bb7-46e8-9089-29d3d835b472 | available |      -       |  1   |      -      |  false   |             |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+


Expected results:
The volumes list should be empty
Comment 2 Sergey Gotliv 2016-02-02 10:03:05 EST

*** This bug has been marked as a duplicate of bug 1303858 ***

Note You need to log in before you can comment on or make changes to this bug.