Bug 1303878 - Gluster: Exceptions are flooded in the RHEVM UI, when there is no activity in Volume's tab Activities column
Gluster: Exceptions are flooded in the RHEVM UI, when there is no activity in...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3
x86_64 Linux
medium Severity high (vote)
: ovirt-4.0.2
: 4.0.2.1
Assigned To: Ramesh N
RamaKasturi
:
Depends On:
Blocks: Gluster-HC-2
  Show dependency treegraph
 
Reported: 2016-02-02 05:18 EST by SATHEESARAN
Modified: 2016-08-17 10:44 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
1. RHEV+RHGS Integration 2. Hyperconvergence
Last Closed: 2016-08-17 10:44:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rnachimu: needinfo-
rule-engine: ovirt‑4.0.z+
rule-engine: exception+
rule-engine: planning_ack+
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)
screenshot of exceptions seen on RHEVM UI (155.25 KB, image/png)
2016-02-02 05:19 EST, SATHEESARAN
no flags Details
UI log file (64.00 KB, text/plain)
2016-02-02 05:20 EST, SATHEESARAN
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54574 None None None 2016-07-01 02:59 EDT
oVirt gerrit 60085 ovirt-engine-4.0 MERGED webadmin: fix UI exceptions in volumes tab 2016-07-05 05:44 EDT

  None (edit)
Description SATHEESARAN 2016-02-02 05:18:23 EST
Description of problem:
-----------------------
When a gluster node/volume is managed in RHEVM 3.6, ofter unhandled exceptions are thrown in the UI

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHEVM 3.6.3

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Add a gluster node to gluster enabled cluster ( or to virt+gluster enabled cluster, in the case of hyperconvergence )
2. Perform any gluster node/volume related tasks ( eg, volume creation, brick creation, getting advanced brick details, volume set, etc )

Actual results:
---------------
An error - "Uncaught exception occurred. Please try reloading the page. Details: (TypeError) __gwt$exception: <skipped>: a is null
Please have your administrator check the UI logs" was noticed on RHEVM UI

Expected results:
-----------------
There shouldn't be any exceptions thrown on RHEVM UI

Additional info:
----------------
Attached the UI logs and screenshot of exceptions caught on RHEVM UI
Comment 1 SATHEESARAN 2016-02-02 05:19 EST
Created attachment 1120371 [details]
screenshot of exceptions seen on RHEVM UI
Comment 2 SATHEESARAN 2016-02-02 05:20 EST
Created attachment 1120372 [details]
UI log file
Comment 3 SATHEESARAN 2016-02-02 05:21:24 EST
Snip of exception errors seen in ui.log

<snip>
2016-02-02 05:11:58,051 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-8) [] Permutation name: 9427A308A8D941A090BA85F4C59BC529
2016-02-02 05:11:58,051 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-8) [] Uncaught exception: : com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: Dab(...) is null
        at Unknown.ms(Unknown Source)
        at Unknown.us(Unknown Source)
        at Unknown.i3(Unknown Source)
        at Unknown.l3(Unknown Source)
        at Unknown.v2(Unknown Source)
        at Unknown.Im(Unknown Source)
        at Unknown.Sm(Unknown Source)
        at Unknown.j$(Unknown Source)
        at Unknown.Km(Unknown Source)
        at Unknown.H6e(Unknown Source)
        at Unknown.kXe(Unknown Source)
        at Unknown.kZe(Unknown Source)
        at Unknown.Yt(Unknown Source)
        at Unknown.au(Unknown Source)
        at Unknown._t/<(Unknown Source)
        at Unknown.uy(Unknown Source)
        at Unknown.l6e(Unknown Source)
        at Unknown.Aol(Unknown Source)
        at Unknown.H6e(Unknown Source)
        at Unknown.kXe(Unknown Source)
        at Unknown.jXe(Unknown Source)
        at Unknown.iZe(Unknown Source)
        at Unknown.Yt(Unknown Source)
        at Unknown.au(Unknown Source)
        at Unknown._t/<(Unknown Source)
        at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: Dab(...) is null
        at Unknown.vrp(Unknown Source)
        at Unknown.Mnl(Unknown Source)
        at Unknown.JAk(Unknown Source)
        at Unknown.E$(Unknown Source)
        at Unknown.d$(Unknown Source)
        at Unknown.F2(Unknown Source)
        ... 22 more
</snip>
Comment 4 Ramesh N 2016-02-11 04:56:12 EST
I see this error whenever i hover over the 'Activites' column in Volumes tab. I could not re-produce this error while doing all volume related operations but carefully not moving the mouse over 'Activites' column. 

Sas: Can u check and confirm?
Comment 5 SATHEESARAN 2016-02-15 03:50:44 EST
(In reply to Ramesh N from comment #4)
> I see this error whenever i hover over the 'Activites' column in Volumes
> tab. I could not re-produce this error while doing all volume related
> operations but carefully not moving the mouse over 'Activites' column. 
> 
> Sas: Can u check and confirm?

Yes, I was under the impression that while performing 'volume' operations, I could hit this bug.

But I was hovering over 'Activities' column under volumes tab, after performing any volume operations from UI. That created an illusion the other way, which made me to think that any volume related operation is causing this issue.
Comment 6 RamaKasturi 2016-02-15 03:52:50 EST
Ramesh, agree with you.

what i have observed is when we are doing some operations in activities column it is consistently reproducible and until we close them we cannot really perform any operation.
Comment 7 RamaKasturi 2016-02-15 04:18:43 EST
Seen "uncaught exception occured. Please try reloading the page." when trying to create a new geo-replication.
Comment 8 Sahina Bose 2016-03-31 05:23:56 EDT
Can you attach the debug info logs to the bug? You need to install the webadmin-debuginfo package to get the logs
Comment 9 Gil Klein 2016-03-31 05:25:51 EDT
(In reply to Sahina Bose from comment #8)
> Can you attach the debug info logs to the bug? You need to install the
> webadmin-debuginfo package to get the logs
Use the following instructions to enable UI debugging

http://www.ovirt.org/uncategorized/engine-debug-obfuscated-ui/
Comment 10 Yaniv Lavi 2016-05-23 09:15:35 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 11 Yaniv Lavi 2016-05-23 09:20:51 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 13 Sandro Bonazzola 2016-07-12 05:58:14 EDT
Moving back to POST since this bug is targeted to 4.0.1 but the patch has not been included in 4.0.1 branch. Please check this bug status and eventually re-target to 4.0.2.
Comment 14 Ramesh N 2016-07-21 07:40:11 EDT
Moving to modified since the patch is already included in 4.0.2 rc1 branch.
Comment 15 RamaKasturi 2016-08-16 09:31:25 EDT
Verified and works fine with build ovirt-engine-4.0.2.6-0.1.el7ev.noarch.

Do not see any exceptions in the UI while creating volume, setting options, retrieving advanced details and performed rebalance,remove-brick operations.

Note You need to log in before you can comment on or make changes to this bug.