Bug 1303912 - drop dependency on WebKit 1 Gtk bindings
drop dependency on WebKit 1 Gtk bindings
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
24
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 07:09 EST by Christian Stadelmann
Modified: 2016-05-20 13:42 EDT (History)
7 users (show)

See Also:
Fixed In Version: eclipse-4.6.0-0.6.git201605092000.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-20 13:42:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 441568 None None None 2016-04-16 11:31 EDT

  None (edit)
Description Christian Stadelmann 2016-02-02 07:09:22 EST
Description of problem:
According to Michael Catanzaro, a developer of WebKitGtk, it is highly discouraged to ever use WebKit 1 (webkitgtk package in Fedora) any more.

When running with Gtk2 backend, SWT is using this WebKit 1 Gtk binding.

Fedora's eclipse package should drop any webkitgtk dependency pretty soon. I know that backwards compatibility is needed for some Eclipse plugins that probably may require Gtk2 in-process with Eclipse/SWT. Is it possible to put those outside the main eclipse-swt package? So "most" users won't see any Webkit 1 Gtk bindings in Eclipse (and thus probably no Gtk2 version of Eclipse). For those few who need that, they can install a separate (new) package named e.g. eclipse-swt-gtk2.

Version-Release number of selected component (if applicable):
eclipse-swt-1:4.5.1-1.fc23
eclipse-swt-1:4.5.1-7.fc23

How reproducible:
always, see spec file
Comment 1 Alexander Kurtakov 2016-02-02 07:21:09 EST
Putting it outside of main eclipse-swt would be giant hack and request for disaster considering how much people insist on certain look from GTK2. 
I would say this can be 3 step effort:
1. Drop webkitgtk1 requires for Fedora 24 - as all webkit calls are dynamic this should have the effect of just non-working internal browser widget for GTK 2 users, as it should open external browser in such cases it's fair compromise for people using GTK2. Mat, please take care of this for Fedora 24.
2. Drop webkitgtk3 requires for Fedora 24 after making SWT default to webkit2 - there is pretty much working widget based on webkit2 but missing some functionality (progress notifications and etc.). Should be doable but needs further testing. Mat, would you please try it and if there are some issues let me know so I hopefully we can achieve that for Fedora 24.
3. Stop compiling GTK 2 backend at all - due to swt build machinery being a giant hack this is something we can only try for Fedora 25 due to time concerns but I was looking for this coming for long time.
Comment 2 Jan Kurik 2016-02-24 10:52:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Fedora Update System 2016-05-03 06:14:38 EDT
ecj-4.5.2-3.fc24 eclipse-4.6.0-0.5.git201604261105.fc24 eclipse-e4-importer-0.2.0-0.1.git8af671a.fc24 eclipse-egit-4.3.0-2.fc24 eclipse-jgit-4.3.0-2.fc24 eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24 tycho-0.25.0-3.fc24 tycho-extras-0.25.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa301aab71
Comment 4 Fedora Update System 2016-05-05 05:54:41 EDT
ecj-4.5.2-3.fc24, eclipse-4.6.0-0.5.git201604261105.fc24, eclipse-cdt-9.0.0-0.3.git0b93e81.fc24, eclipse-e4-importer-0.2.0-0.1.git8af671a.fc24, eclipse-ecf-3.13.1-1.fc24, eclipse-eclemma-2.3.3-2.fc24, eclipse-egit-4.3.0-2.fc24, eclipse-jgit-4.3.0-2.fc24, eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24, eclipse-linuxtools-5.0.0-0.1.gitc2364c0.fc24, eclipse-photran-9.1.0-3.fc24, eclipse-ptp-9.0.2-2.fc24, eclipse-pydev-4.6.0-1.fc24, eclipse-swtbot-2.4.0-2.fc24, tycho-0.25.0-3.fc24, tycho-extras-0.25.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa301aab71
Comment 5 Fedora Update System 2016-05-06 06:03:53 EDT
ecj-4.5.2-3.fc24 eclipse-4.6.0-0.5.git201604261105.fc24 eclipse-cdt-9.0.0-0.3.git0b93e81.fc24 eclipse-e4-importer-0.2.0-0.1.git8af671a.fc24 eclipse-ecf-3.13.1-1.fc24 eclipse-eclemma-2.3.3-2.fc24 eclipse-egit-4.3.0-2.fc24 eclipse-fedorapackager-0.6.0-0.1.gitb0ca8af.fc24 eclipse-jgit-4.3.0-2.fc24 eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24 eclipse-linuxtools-5.0.0-0.1.gitc2364c0.fc24 eclipse-photran-9.1.0-3.fc24 eclipse-ptp-9.0.2-2.fc24 eclipse-pydev-4.6.0-1.fc24 eclipse-swtbot-2.4.0-2.fc24 tycho-0.25.0-3.fc24 tycho-extras-0.25.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa301aab71
Comment 6 Fedora Update System 2016-05-07 13:27:21 EDT
ecj-4.5.2-3.fc24, eclipse-4.6.0-0.5.git201604261105.fc24, eclipse-cdt-9.0.0-0.3.git0b93e81.fc24, eclipse-e4-importer-0.2.0-0.1.git8af671a.fc24, eclipse-ecf-3.13.1-1.fc24, eclipse-eclemma-2.3.3-2.fc24, eclipse-egit-4.3.0-2.fc24, eclipse-fedorapackager-0.6.0-0.1.gitb0ca8af.fc24, eclipse-jgit-4.3.0-2.fc24, eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24, eclipse-linuxtools-5.0.0-0.1.gitc2364c0.fc24, eclipse-photran-9.1.0-3.fc24, eclipse-ptp-9.0.2-2.fc24, eclipse-pydev-4.6.0-1.fc24, eclipse-swtbot-2.4.0-2.fc24, tycho-0.25.0-3.fc24, tycho-extras-0.25.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa301aab71
Comment 7 Fedora Update System 2016-05-12 03:42:42 EDT
ecj-4.5.2-3.fc24 eclipse-4.6.0-0.6.git201605092000.fc24 eclipse-cdt-9.0.0-0.3.git0b93e81.fc24 eclipse-e4-importer-0.2.0-0.1.git8af671a.fc24 eclipse-ecf-3.13.1-1.fc24 eclipse-eclemma-2.3.3-2.fc24 eclipse-egit-4.3.0-2.fc24 eclipse-emf-2.12.0-0.1.git2021583.fc24 eclipse-fedorapackager-0.6.0-0.1.gitb0ca8af.fc24 eclipse-jgit-4.3.0-2.fc24 eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24 eclipse-linuxtools-5.0.0-0.1.gitc2364c0.fc24 eclipse-photran-9.1.0-3.fc24 eclipse-ptp-9.0.2-2.fc24 eclipse-pydev-4.6.0-1.fc24 eclipse-swtbot-2.4.0-2.fc24 tycho-0.25.0-3.fc24 tycho-extras-0.25.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa301aab71
Comment 8 Fedora Update System 2016-05-15 02:57:56 EDT
ecj-4.5.2-3.fc24, eclipse-4.6.0-0.6.git201605092000.fc24, eclipse-cdt-9.0.0-0.3.git0b93e81.fc24, eclipse-e4-importer-0.2.0-0.2.gitb33919c.fc24, eclipse-ecf-3.13.1-1.fc24, eclipse-eclemma-2.3.3-2.fc24, eclipse-egit-4.3.0-2.fc24, eclipse-emf-2.12.0-0.1.git2021583.fc24, eclipse-fedorapackager-0.6.0-0.1.gitb0ca8af.fc24, eclipse-jgit-4.3.0-2.fc24, eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24, eclipse-linuxtools-5.0.0-0.1.gitc2364c0.fc24, eclipse-photran-9.1.0-3.fc24, eclipse-ptp-9.0.2-2.fc24, eclipse-pydev-4.6.0-1.fc24, eclipse-swtbot-2.4.0-2.fc24, tycho-0.25.0-3.fc24, tycho-extras-0.25.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa301aab71
Comment 9 Fedora Update System 2016-05-20 13:42:31 EDT
ecj-4.5.2-3.fc24, eclipse-4.6.0-0.6.git201605092000.fc24, eclipse-cdt-9.0.0-0.3.git0b93e81.fc24, eclipse-e4-importer-0.2.0-0.2.gitb33919c.fc24, eclipse-ecf-3.13.1-1.fc24, eclipse-eclemma-2.3.3-2.fc24, eclipse-egit-4.3.0-2.fc24, eclipse-emf-2.12.0-0.1.git2021583.fc24, eclipse-fedorapackager-0.6.0-0.1.gitb0ca8af.fc24, eclipse-jgit-4.3.0-2.fc24, eclipse-launchbar-2.0.0-0.1.git1f95c6c.fc24, eclipse-linuxtools-5.0.0-0.1.gitc2364c0.fc24, eclipse-photran-9.1.0-3.fc24, eclipse-ptp-9.0.2-2.fc24, eclipse-pydev-4.6.0-1.fc24, eclipse-swtbot-2.4.0-2.fc24, tycho-0.25.0-3.fc24, tycho-extras-0.25.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.