Bug 1303930 - Integration tests fails for database
Integration tests fails for database
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: John W. Lamb
Wang Haoran
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 07:52 EST by Jaspreet Kaur
Modified: 2016-02-04 06:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 10:31:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaspreet Kaur 2016-02-02 07:52:49 EST
Description of problem:

Jenkins runs the test cases after the build.  The tests attempt to connect to the applications Postgres DB with the following URL:
postgresql://adminimzdq7i:PASSWORD_REMOVED@127.3.66.2:5432/test

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

It should work

Expected results:

Below error is seen :

info: No Winston logging transports configured- using console logger
warn: Twilio has not been configured with an authToken and accountSid. No SMS will be sent.
Unhandled rejection SequelizeHostNotReachableError: connect EHOSTUNREACH
    at node_modules/sequelize/lib/dialects/postgres/connection-manager.js:95:20
    at null.<anonymous> (node_modules/pg/lib/client.js:176:5)
    at Socket.<anonymous> (node_modules/pg/lib/connection.js:59:10)
    at net.js:441:14
Build step 'Execute shell' marked build as failure
Archiving artifacts
Recording test results
ERROR: Publisher hudson.tasks.junit.JUnitResultArchiver aborted due to exception
java.io.IOException: remote file operation failed: /var/lib/openshift/56a98ddb7628e160f000003c/app-root/runtime/repo at hudson.remoting.Channel@1eb87e2:devbldr: java.io.IOException: Failed to read /var/lib/openshift/56a98ddb7628e160f000003c/app-root/runtime/repo/.bowerrc
Is this really a JUnit report file? Your configuration must be matching too many files


Additional info:

From the Jenkins gear (jenkins-safeline.rhcloud.com), attempting to access the application gear: (dev sd.psafe.mobi)
Comment 1 Dan McPherson 2016-02-02 10:31:54 EST
This case wasn't supported in v2.  Only the web framework is instantiated for jenkins builds.

Note You need to log in before you can comment on or make changes to this bug.