Bug 1303959 - When the Openstack cloud provider AMQP server isn't reachable an Unknown reason is shown for credentials validation
When the Openstack cloud provider AMQP server isn't reachable an Unknown reas...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ola Pavlenko
openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 09:25 EST by Marius Cornea
Modified: 2017-08-29 23:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:35:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2016-02-02 09:25:49 EST
Description of problem:
When the Openstack cloud provider AMQP server isn't reachable an Unknown reason is shown for credentials validation.

Version-Release number of selected component (if applicable):
5.5.2.4.20160127105142_395c086

How reproducible:
100%

Steps to Reproduce:
1. Add an Openstack OSP 7 Cloud provider
2. Input the public API VIP 
3. Input the AMQP credentials
4. Validate credentials

Actual results:
Credential validation was not successful: Unknown reason

Expected results:
The error message actually shows the connection failure reason. 

If we manually check the AMQP connection from CLI we can see:
[root@cloudforms ~]# curl -g http://[2001:db8:fd00:1000::10]:5672
curl: (7) Failed connect to 2001:db8:fd00:1000::10:5672; Connection refused

So I believe a proper message would be:
Credential validation was not successful: Connection refused
Comment 2 Shveta 2016-02-02 19:13:13 EST
Assigning to add test case
Comment 4 CFME Bot 2016-05-20 10:40:47 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/5ad1662e596e7a598acfd93f7b0ae4734fe1f2cc

commit 5ad1662e596e7a598acfd93f7b0ae4734fe1f2cc
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Thu May 12 15:51:17 2016 +0200
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Mon May 16 17:26:14 2016 +0200

    Do not hide AMQP exception for validation
    
    Do not hide AMQP exception for validation
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1303959

 .../manageiq/providers/openstack/manager_mixin.rb  |  7 +++++--
 .../events/openstack_ceilometer_event_monitor.rb   |  2 +-
 .../events/openstack_rabbit_event_monitor.rb       |  2 +-
 gems/pending/openstack/openstack_event_monitor.rb  | 24 +++++++++++++---------
 4 files changed, 21 insertions(+), 14 deletions(-)
Comment 5 Ronnie Rasouli 2016-06-08 06:59:51 EDT
Validated on cfme 5.6.0.9 rc2 credentials for rabbitmq validation successful
Comment 7 errata-xmlrpc 2016-06-29 11:35:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.