Bug 1303979 - OOM with kernel 4.3.x (regression)
OOM with kernel 4.3.x (regression)
Status: CLOSED DUPLICATE of bug 1303270
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-02-02 10:34 EST by Stuart D Gathman
Modified: 2016-02-03 03:16 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-02-03 03:16:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
oom log (39.86 KB, text/plain)
2016-02-02 11:11 EST, Stuart D Gathman
no flags Details
systemd-jrournal gets the axe (22.04 KB, text/plain)
2016-02-02 11:27 EST, Stuart D Gathman
no flags Details

  None (edit)
Description Stuart D Gathman 2016-02-02 10:34:16 EST
Description of problem:
When booted from 4.3 kernels, laptop starts killing process for OOM within 8 hours.

Version-Release number of selected component (if applicable):

How reproducible:
Always, but no hard timeline.

Steps to Reproduce:
1. Boot with 4.3.4 (hang on to last working kernel-4.2.8)
2. Do stuff.  Network seems important

Actual results:
OOM, with userspace memory only 50% used.

Expected results:
Same stable operation as 4.2.8 kernel.

Additional info:
Adding a USB wifi dongle (for a total of 2 connected wifi nets) seemed to cut time to OOM in half.  But this was subjective and squishy.  Haven't done it often enough to quantify.

This is different from https://bugzilla.redhat.com/show_bug.cgi?id=1303270 in that SUnreclaim is not increasing without bound.  However, it is similar in that user space processes don't seem to be using the memory. (And in 4.3 kernel being generally borked.)  I'll be adding logs and another regression for intel video.
Comment 1 Stuart D Gathman 2016-02-02 11:11 EST
Created attachment 1120490 [details]
oom log

This may be related to bug#1303990, as video was "jumpy" prior to the OOMs, and firefox was using more memory than for the same set of tabs with 4.2.8.  Thunderbird is always a pig, but the OOMs follow 4.3 kernels.
Comment 2 Stuart D Gathman 2016-02-02 11:18:01 EST
Note, while the OOM handler starts with killing thunderbird and firefox (the biggest pigs), it continues killing processes, including mate-panel, various applets, etc, until the desktop is empty!  It only seems to kill processes using X, however.  Which is why I think bug#1303990 might be related.
Comment 3 Stuart D Gathman 2016-02-02 11:27 EST
Created attachment 1120497 [details]
systemd-jrournal gets the axe
Comment 4 Josh Boyer 2016-02-03 03:16:37 EST

*** This bug has been marked as a duplicate of bug 1303270 ***

Note You need to log in before you can comment on or make changes to this bug.