Bug 1304007 - [Cinder] Creation of a snapshot with cinder disks is reported as failed: "Failed to complete snapshot.."
[Cinder] Creation of a snapshot with cinder disks is reported as failed: "Fai...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.2.6
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.3
: 3.6.3.2
Assigned To: Maor
Natalie Gavrielov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 11:40 EST by Natalie Gavrielov
Modified: 2016-02-22 07:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 07:39:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
amureini: exception?
ylavi: planning_ack+
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
engine.log (9.82 MB, text/plain)
2016-02-02 11:40 EST, Natalie Gavrielov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53510 ovirt-engine-3.6 MERGED core: adding CreateAllCinderSnapshotsCommand 2016-02-15 12:30 EST
oVirt gerrit 53526 ovirt-engine-3.6.3 MERGED core: adding CreateAllCinderSnapshotsCommand 2016-02-15 12:50 EST

  None (edit)
Description Natalie Gavrielov 2016-02-02 11:40:41 EST
Created attachment 1120514 [details]
engine.log

Description of problem:

Creation of a snapshot with cinder disks is reported as failed:

Version-Release number of selected component (if applicable):
rhevm-3.6.2.6-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:

Create a snapshot from a VM with cinder disks.

Actual results:
Operation seems to complete properly, but the following error appears:
2016-01-31 15:26:04,565 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-98) [22fed514] Correlation ID: 34e4dc39, Job ID: b49514ac-e034-4377-a400-fac15562ec38, Call Stack: null, Custom Event ID: -1, Message: Failed to complete snapshot 'snap-1' creation for VM 'cinder-vm-1'.

Expected results:

Complete successfully.
Comment 1 Allon Mureinik 2016-02-03 01:40:07 EST
Natalie - AFAIK, this was not the behavior in 3.6.1, making this a regression. Can you confirm/refute?
Comment 2 Maor 2016-02-04 05:06:54 EST
The issue here is creating a snapshot with images and Cinder volumes.
There is a running VM with two Cinder disks and a live snapshot is being issued.

The operation makes 4 snapshots,
 2 of them for Cinder volumes,
 and the other 2 for images (memory and VM configuration).

The logic in the Command Coordinator has been changed drastically at ovirt 4.0.

Natalie, does the problem is only with the audit log, or there are other issues here?
Comment 3 Natalie Gavrielov 2016-02-07 04:18:54 EST
(In reply to Maor from comment #2)
> Natalie, does the problem is only with the audit log, or there are other
> issues here?

I Haven't notice any other impact..

Note You need to log in before you can comment on or make changes to this bug.