Bug 1304024 - [RFE] Permit modifying policy.json files for openstack services based on config needs
[RFE] Permit modifying policy.json files for openstack services based on conf...
Status: CLOSED DUPLICATE of bug 1304025
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
x86_64 Linux
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Hugh Brock
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2016-02-02 12:12 EST by Freddy Wissing
Modified: 2016-04-18 03:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-02-03 11:43:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Freddy Wissing 2016-02-02 12:12:31 EST
Customer use case is as a hosting provider requires control access and permission within the stack in a granular fashion.  The way that this is done (presently) is through the use of each component's policy.json file.  

The ability to automate this via puppet or heat template at time of deploy would be a nice feature to have as it would assist in consolidating the post deployment actions that are being done and allow for a structured approach in crafting specialized permissions.


Additional info

Due to the nature of hosting, this customer would like to have the ability to dictate during the initial data dump into director to add the configuration changes to each components policy.json file.  This would allow for the services to be hardened at the time of deployment rather than either being scripted out later or a manual process post deploy.
Comment 2 Mike Burns 2016-02-03 11:43:20 EST

*** This bug has been marked as a duplicate of bug 1304025 ***

Note You need to log in before you can comment on or make changes to this bug.