Bug 1304043 - Remove Manila from Packstack
Remove Manila from Packstack
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ga
: 8.0 (Liberty)
Assigned To: Ivan Chavero
Yogev Rabl
: TestOnly, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 12:59 EST by Dustin Schoenbrun
Modified: 2016-04-26 20:09 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-packstack-7.0.0-0.14.dev1702.g490e674.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-15 09:47:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of file and glance commands (588 bytes, text/plain)
2016-02-02 12:59 EST, Dustin Schoenbrun
no flags Details
0003-Remove-the-Manila-plugin.patch (50.49 KB, patch)
2016-03-23 21:11 EDT, Ivan Chavero
no flags Details | Diff

  None (edit)
Description Dustin Schoenbrun 2016-02-02 12:59:16 EST
Created attachment 1120524 [details]
Output of file and glance commands

Description of problem:
During the installation of OSP-8 via Packstack, it appears that Packstack downloads the service image for the Manila Generic Share Driver and places it into Glance. The problem is that the link specified leads to a redirect, which is then downloaded as the Manila service image as the HTML redirect. This causes the Manila service image to never be able to boot as the image itself is not present. We will need to change the logic to either point to the correct link or correctly handle the HTML redirect to get the image.

Version-Release number of selected component (if applicable):
openstack-packstack-puppet-7.0.0-0.10.dev1684.g87ec498.el7ost.noarch
puppet-3.6.2-3.el7.noarch
openstack-puppet-modules-7.0.3-1.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Download and install the openstack-packstack packages
2. Generate an answer file using packstack and enable the installation of Manila.
3. Look at the Glance image that was downloaded (defaults to /var/lib/glance/images) and see that the image is HTML text.

Actual results:
The Manila service image is an HTML document containing the redirect to download the image from a different Dropbox location.

Expected results:
The Manila service image is downloaded and put into Glance successfully and Manila service instances shall boot and operate successfully.
Comment 6 Alan Pevec 2016-02-19 16:50:45 EST
What is actually inside that manila service ubuntu-based image?

I don't see it mentioned in the Netapp's Manila guide:
http://netapp.github.io/openstack-deploy-ops-guide/liberty/content/manila.netapp.drivers.html
Comment 7 Dustin Schoenbrun 2016-02-19 16:57:13 EST
(In reply to Alan Pevec from comment #6)
> What is actually inside that manila service ubuntu-based image?
The service image is essentially a thoroughly stripped version of Ubuntu 12.04 LTS that has the essentials needed for exporting Cinder Volumes mounted to it as NFS and CIFS shares.

> 
> I don't see it mentioned in the Netapp's Manila guide:
> http://netapp.github.io/openstack-deploy-ops-guide/liberty/content/manila.
> netapp.drivers.html
It probably wouldn't be. The Manila Service Image is only used with the Generic Share Driver. Other drivers, such as NetApp's, do not rely on it. Hope this helps!
Comment 8 Martin Magr 2016-02-24 04:05:24 EST
Hi Dustin, do we have such image based on Fedora/CentOS available somewhere?
Comment 10 Dustin Schoenbrun 2016-02-24 10:05:39 EST
(In reply to Martin Magr from comment #8)
> Hi Dustin, do we have such image based on Fedora/CentOS available somewhere?

Currently, no. There is a project called Manila Image Elements on GitHub (https://github.com/openstack/manila-image-elements) that provides the means for creating the service image. A quick look at the source tree seems to reveal that the only target it supports is Ubuntu. There would need to be some sort of effort to make it able to target Fedora or CentOS.
Comment 11 Ivan Chavero 2016-03-23 21:11 EDT
Created attachment 1139809 [details]
0003-Remove-the-Manila-plugin.patch

At the moment there are no RHEL or CentOS manila images, there
are only ubuntu images. It's not appropiate to install ubuntu
images under OSP so we're removing the manila plugin until we
have Red Hat images.
Comment 12 Ivan Chavero 2016-03-23 21:55:25 EDT
Can i have acks for this bug?
Comment 23 Yogev Rabl 2016-04-10 09:08:31 EDT
verified on openstack-packstack-2015.1-0.16.dev1589.g1d6372f.el7ost.noarch
Comment 25 errata-xmlrpc 2016-04-15 09:47:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0636.html

Note You need to log in before you can comment on or make changes to this bug.