Bug 130408 - logitech cordless desktop express backspace problem
logitech cordless desktop express backspace problem
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 00:24 EDT by r pallucchini
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-17 14:53:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description r pallucchini 2004-08-20 00:24:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
after i digit a space key the backspace don't work correctly, the 
cursor go back for a character and return a step next then wait 
sometime and repeat spaces forever, for stop it i need to press a 
key. The problem seems appare only after a space key pressed, in all 
the start mode (init 3 / 5) and during install too.

The ps is an Athlon 64 3200+, mb asus k8v, 1Gb ram, logitech cordless 
desktop express



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open a terminal
2. press space key
3. press backspace key
    

Actual Results:  the cursor make a step back and forward and start to 
repeat the spaces

Expected Results:  erase the space

Additional info:
Comment 1 r pallucchini 2004-08-29 17:01:05 EDT
after a deep check i have found a new clues for correct it. first the
problem is into the kernel and seems that when i press backspace key
it generate a press event and a release, but after arrive two unknown
 signals and another space key pressed without release. in some cases
i have see other unknown signal when i press a letter or other keys...
but it appened in very few times.
below the test with showkey program: 

[root@fcath64 root]# showkey
kb mode was UNICODE
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
keycode  28 release
keycode  46 press
keycode  46 release
keycode  14 press
keycode  14 release
atkbd.c: Unknown key released (translated set 2, code 0xe1 on
isa0060/serio0).
atkbd.c: Use 'setkeycodes e061 <keycode>' to make it known.
atkbd.c: Unknown key released (translated set 2, code 0x65 on
isa0060/serio0).
atkbd.c: Use 'setkeycodes 65 <keycode>' to make it known.
keycode  57 press
keycode  57 press
keycode  57 release
Comment 2 Eido Inoue 2005-02-17 14:53:34 EST
can't seem to reproduce this with the given info.

Note You need to log in before you can comment on or make changes to this bug.