Bug 1304101 - 3.1.0.4->3.1.1.6 registry health check not updated
3.1.0.4->3.1.1.6 registry health check not updated
Status: CLOSED DUPLICATE of bug 1302956
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 16:47 EST by Wesley Hearn
Modified: 2016-02-04 13:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 13:23:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Hearn 2016-02-02 16:47:52 EST
Description of problem:
With 3.1.1.6 the health check for the registry changed from /healthz to /
During the upgrade the DC did not get updated and caused the registry to get restarted every 10 secs.

Version-Release number of selected component (if applicable):
3.1.1.6

How reproducible:
Often

Steps to Reproduce:
1. Install 3.1.0.4-1.git.15.5e061c3.el7aos
2. Upgrade cluster
3. Watch oc get events -w and see registry get restarted

Actual results:
registry gets restarted every health check

Expected results:
registry to stay up

Additional info:
Comment 1 Scott Dodson 2016-02-03 15:54:33 EST
For what it's worth, when I tried to reproduce this based on our IRC discussions I found that I had no liveness probes created under v3.1.0.4 and v3.1.1.6 worked fine in the default config.

Is your registry secured? If so it's probably a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1302956
Comment 2 Wesley Hearn 2016-02-03 16:33:23 EST
It is secured. We may gave flipped it to secure when we upgraded so it would have had the 3.1.0.4 data that is there when a new 3.1.1.6 cluster is built.
Comment 3 Scott Dodson 2016-02-04 13:23:29 EST
The registry had to have been re-created under v3.1.1.6 and then secured which would've caused the health check to start failing because the documentation at the time lacked a step to switcht he liveness probe from HTTP to HTTPS.

*** This bug has been marked as a duplicate of bug 1302956 ***

Note You need to log in before you can comment on or make changes to this bug.