Bug 130413 - RFE: Ability to write subnet masks normally (ie, VLSN or CIDR).
RFE: Ability to write subnet masks normally (ie, VLSN or CIDR).
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-netboot (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fabio Olive Leite
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 03:02 EDT by Mike MacCana
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2004-08-20 03:02:18 EDT
Description of problem:
When adding a bunch of options for a particular subnet, the format
used by system-config-netboot is confusing. Yes, we both know the
files used in the background are matched by removing digits from the
IP, but it shouldn't be necessary for people to know that.

It'd be nice if the tool let people write in subnet masks the same way
the other system-config tools do. Upon clicking OK, the tool would
check to make sure masks entered this way were possible to use with TFTP.

Version-Release number of selected component (if applicable):
0.1.3-7

How reproducible:
Always

Steps to Reproduce:
1.Want to set up network booting for a particular subnet. Enter in the
subnet using VLSN just like all the other system-config tools.
  
Actual results:
This doesn't work. The subnet mask must be written in a rather unusual
way. The tooltips and System Admin guide don't make this particular
obvious either.

Expected results:
It'd be nice if using VLSN was possible. This would make things easier
and more consistent with other system-config- tools.

Additional info:
Thanks.
Comment 1 Suzanne Hillman 2004-09-10 16:32:09 EDT
Internal RFE bug #132312 entered; will be considered for future releases.
Comment 2 Jason Vas Dias 2005-06-01 20:37:38 EDT
I clearing out some old bugs here - sorry for the delay .
This can't really be fixed in s-c-nb, because PXE doesn't really
work that way: the PXE client boot code looks for a file named 
with each whole BYTE of the hex IP address, which can't really
be specified with VLSP / CIDR notation, which allows individual
BITS to be specified . 
The s-c-db "New Host" dialog does let you omit whole bytes from the
IP address and creates files accordingly.
Please try out the latest s-c-nb for RHEL-3:
 redhat-config-netboot-0.1.16 
http://people.redhat.com/~jvdias/redhat-config-netboot
Thanks !
 
Comment 3 Mike MacCana 2005-06-01 23:25:04 EDT
This can't really be fixed in s-c-nb, 

Er, yes it can.

User enters subnet mask.
If the subnet mask doesn't cover a whole byte range, ask the user to
enter another.

Comment 5 Red Hat Bugzilla 2007-02-05 14:04:52 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 6 RHEL Product and Program Management 2007-10-19 15:19:58 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.