Bug 130414 - New Kernel breaks K3B (detect burners as cdrom drives)
New Kernel breaks K3B (detect burners as cdrom drives)
Status: CLOSED DUPLICATE of bug 130576
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 03:58 EDT by drago01
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg (12.03 KB, text/plain)
2004-08-20 03:59 EDT, drago01
no flags Details

  None (edit)
Description drago01 2004-08-20 03:58:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
After updating the kernel via rawhide k3b stopped working.
It doesn't detect my dvd bruner and cd burner as burners but as normal
cdrom/dvd rom drives. (cdrecord -scnabus also shows nothing).
I am not using ide-scsi.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1.boot the new kernel
2. start k3b
3. try to burn anything
    

Actual Results:  Burners are not detected

Expected Results:  Burners should be detected

Additional info:

Maybe it has somthing to do with this known bug:
http://bugs.kde.org/show_bug.cgi?id=87211
Comment 1 drago01 2004-08-20 03:59:19 EDT
Created attachment 102915 [details]
output of dmesg
Comment 2 Arjan van de Ven 2004-08-20 04:00:47 EDT
does this work when run as root ?
Comment 3 drago01 2004-08-20 04:10:48 EDT
yes it does...
Comment 4 Steven Op de beeck 2004-08-20 09:40:01 EDT
I have the same problem with kernel-2.6.8-1.524. It somehow fails to
detect writing support on regular cd burners and dvd burners. DVD
write support isn't affected though.
I tried it with kernel-2.6.7-1.494.2.2, and that works without problem.
Comment 5 Steven Op de beeck 2004-08-20 10:31:45 EDT
The above is not entirely accurate.
DVD-R(W) support is detected
DVD+R(W) support is NOT
CD write is NOT
CD(RW) is detected

I don't know if this means something. Or if it's correct, but that
just what k3b reports.
Comment 6 To Luis 2004-08-20 12:15:59 EDT
The same problem over here too: 
After installing kernel-2.6.8-1.521 , my cd burner was only recognized
as reader (without writing capabilities) under k3b (TEAC CD-R56S). 
Only as root everything was properly detected.
Since it's only a CD writer, I can't say about other burning 
possibilities mentioned earlier.

Moved back to 2.6.7, to have it working again.

Comment 7 Jeremy Sanders 2004-08-24 12:24:20 EDT
Yes - I'm seeing this with the update too. Our cdrecord is setuid
(owned by root). The drive is an LG RW/DVD GCC-4320B

Logged in as root, cdrecord works. If logged in as another user the
setuid cdrecord doesn't work. Even with the permissions of the devices
open to all, cdrecord fails.

It says

"cdrecord: Cannot init drive."
Comment 8 Adam Bowns 2004-08-24 12:34:30 EDT
Don't try to record audio cd's as root with this kernel because there
is a memory leak that will eventually crash your system.

If you need to burn audio cd's you need the following patches.

http://kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.8.1/2.6.8.1-mm3/broken-out/bio_uncopy_user-mem-leak.patch

http://kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.8.1/2.6.8.1-mm3/broken-out/bio_uncopy_user-mem-leak-fix.patch

There is more info on this at the lkml at

http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&c2coff=1&th=dbce4a618e91ea4&seekm=2vbef-2oe-11%40gated-at.bofh.it#link10

I can confirm that these patches fix the mem leak and the audio cd's
produced are not corrupt... it doesn't fix the executing as normal
user problem though.
Comment 9 Bastien Nocera 2004-08-25 06:45:16 EDT

*** This bug has been marked as a duplicate of 130576 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:05:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.