Bug 1304142 - ospd-8 poodle 2016-02-02.1 deploys and gets create complete, but return code of deploy command is non zero
ospd-8 poodle 2016-02-02.1 deploys and gets create complete, but return code ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-cloud-config (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Jay Dobies
Alexander Chuzhoy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 19:29 EST by wes hayutin
Modified: 2016-04-07 17:46 EDT (History)
10 users (show)

See Also:
Fixed In Version: os-cloud-config-0.3.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:46:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2016-02-02 19:29:41 EST
Description of problem:

Poodle
2016-02-02.1

Seeing:
 750928f7-d69b-4c18-ba5d-74d2698578fa | Stack CREATE completed successfully | CREATE_COMPLETE    | 2016-02-02T23:38:55 |\n

01:54:40.257 | 22f067b4-f43a-482c-91f2-523ff5e12035 | overcloud  | CREATE_COMPLETE | 2016-02-02T23:06:19 | None 

However the return code of the openstack overcloud deploy = 1, this should be 0


source /home/stack/stackrc; openstack overcloud deploy --debug --log-file overcloud_deployment_7.log --templates --libvirt-type=qemu --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server 10.5.26.10 --control-scale 3 --compute-scale 1 --ceph-storage-scale 0 --block-storage-scale 0 --swift-storage-scale 0 --control-flavor baremetal --compute-flavor baremetal --ceph-storage-flavor baremetal --block-storage-flavor baremetal --swift-storage-flavor baremetal --timeout=90 -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/net-single-nic-with-vlans.yaml -e ~/network-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml
Comment 2 Brad P. Crochet 2016-02-03 09:50:07 EST
os-cloud-config needs this patch downstream: https://github.com/openstack/os-cloud-config/commit/1c79a4b9968ef051d2a3d1540432d256ab12ac48
Comment 4 Alexander Chuzhoy 2016-03-09 15:23:13 EST
Verified:

Environment:
os-cloud-config-0.4.0-1.el7ost.noarch

Overcloud Endpoint: https://x.x.x.x:13000/v2.0
Overcloud Deployed
[stack@undercloud72 ~]$ echo $?
0
Comment 6 errata-xmlrpc 2016-04-07 17:46:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.