Bug 1304149 - Unable to recover from certain bad values.
Unable to recover from certain bad values.
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity high
: ga
: 1.0
Assigned To: Jason Montleon
James Olin Oden
: Triaged
Depends On:
Blocks: rhci-sprint-16 qci-sprint-17
  Show dependency treegraph
 
Reported: 2016-02-02 20:47 EST by John Matthews
Modified: 2016-09-13 12:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:25:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2016-02-02 20:47:22 EST
Description of problem:

During hackathon we ran across an instance of a user entering bad values in fusor-installer, subsequent runs with correct values were not honored and machine was broken.




Steps to Reproduce:
1. Use an ISO install of RHCI
2. Enter the correct IP address, say 192.168.155.10
3. Enter all other IP related values incorrect as 192.169.155.1,
   ensure ALL other entries are wrong, unsure which one causes the problem, set all to incorrect values.

4. Proceed with install and see NTP warning
5. Attempt to fix errors and enter 192.168.155.1 and other correct values for the environment.

See that the issue is not fixed and still broken.
Comment 1 Eric Dubé 2016-02-03 08:15:53 EST
The only additional information to add is that when you re-run fusor_installer and fix all the bad IP related values (with the exception of the IP Address which is correct) it will still report an NTP connectivity warning. 

It never actually uses the new IP Address information that you just entered or restarts the networking on the system.

IP Settings used to reproduce:

3. IP address: 192.168.155.10
4. Hostname: sat61fusor.example.com
5. Network mask: 255.255.255.0
6. Network address: 192.169.155.0
7. Host gateway: 192.168.155.1
8. DHCP range start[[BR]]: 192.169.155.11
9. DHCP range end: 192.169.155.250
10. DHCP Gateway: 192.169.155.1
11. DNS forwarder: 192.169.155.1
14. NTP sync host: clock.redhat.com
Comment 2 Jason Montleon 2016-03-21 12:22:13 EDT
This is because the DNS forwarder address is bad. We may want to add a forwarder check as we did for NTP to ensure that they entered a valid DNS server. It will be impossible to check until after networking is set up though.
Comment 8 Jason Montleon 2016-08-05 12:01:52 EDT
Can you please re-test this. I'm having trouble getting stuck and reproducing this. It's possible with all the changes it's no longer possible.

If you can reproduce it can you please provide steps for input that gets you there?
Comment 9 James Olin Oden 2016-08-17 11:03:52 EDT
Verified in QCI-1.0-RHEL-7-20160816.t.0

Ran procedure above and was able to recover.
Comment 11 errata-xmlrpc 2016-09-13 12:25:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.