Bug 130417 - kprinter is scrambled in Japanese
kprinter is scrambled in Japanese
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: i18n
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-20 05:19 EDT by Nakai
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 03:20:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot with an arrow to note (45.21 KB, image/png)
2004-08-20 05:24 EDT, Nakai
no flags Details
Screenshot of kprinter in the ja locale (137.69 KB, image/png)
2004-09-06 01:58 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Nakai 2004-08-20 05:19:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6) Gecko/20040510

Description of problem:
kprinter is scrambled in Japanese.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run kprinter
2. Select printer
3. Press property button
    

Actual Results:  Scrambled.

Expected Results:  Headable text.

Additional info:

Seems to be UTF-8 <-> EUC-JP convert problem.
And might happen for Chinese and Korean too.

Paper selection will cause severe problem for users.
So I set severity high.
Comment 1 Nakai 2004-08-20 05:24:38 EDT
Created attachment 102916 [details]
Screenshot with an arrow to note
Comment 2 Ngo Than 2004-08-20 06:17:12 EDT
Nakai, could you please update to qt-3.3.3 and kde-3.3.0 and try again.
Comment 3 Lawrence Lim 2004-09-06 01:58:31 EDT
Created attachment 103500 [details]
Screenshot of kprinter in the ja locale
Comment 4 Lawrence Lim 2004-09-06 02:01:17 EDT
Unfortunately I could not reproduce the result. I used kde-3.3 and
qt-3.3 for the screenshot. 

I presume this bug has been fixed. Nakai-san, please reopen the bug if
problem persist.
Comment 5 Nakai 2004-11-08 01:24:21 EST
Reopen - still happens on my FC3.


[nakai@dhcp100 ~]$ rpm -q kdelibs qt
kdelibs-3.3.0-5
qt-3.3.3-8
[nakai@dhcp100 ~]$
Comment 6 Ngo Than 2004-11-08 04:17:31 EST
sorry, it's very strange, i cannot reproduce this problem in FC3 with

  kdelibs-3.3.0-5
  qt-3.3.3-8

i started kprinter with LANG=ja_JP.UTF-8 and LANG=ja_JP, and it works.
Could someone else reproduce this problem? Nakai, Could you please
find out why it happens on your machine? Thanks

Comment 7 Nakai 2004-11-08 06:22:45 EST
Similar problem happens on OpenOffice.org.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138317

I guess the scrambled text is generated by CUPS server or so
and all my server runs with Japanese locale at start time.
And I guess KDE or OOo needs some fix in each.

Comment 8 Leon Ho 2005-05-16 22:10:34 EDT
Jens or Tagoh, can you get this tested on your end? I suspect originally it
maybe because the CUPS server has different type of encoding.
Comment 9 Akira TAGOH 2005-05-19 03:20:19 EDT
It looks good to me. tried with:
qt-3.3.4-12
kdelibs-3.4.0-6
kdebase-3.4.0-5

but the same problem still appears on OOo, though.

Note You need to log in before you can comment on or make changes to this bug.