Bug 1304236 - Table width for all pages didn't fit its size well with browser's on IE11
Table width for all pages didn't fit its size well with browser's on IE11
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Robb Hamilton
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 01:25 EST by yapei
Modified: 2016-05-12 13:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:09:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OverviewPage (45.49 KB, image/png)
2016-02-03 01:25 EST, yapei
no flags Details
TableLength (83.67 KB, image/png)
2016-02-03 01:25 EST, yapei
no flags Details
BuildConfigurationTab (69.92 KB, image/png)
2016-02-03 01:30 EST, yapei
no flags Details
BuildEnvironment (55.66 KB, image/png)
2016-02-03 01:31 EST, yapei
no flags Details
Edge 20 showing Events page (612.55 KB, image/png)
2016-02-03 15:43 EST, Robb Hamilton
no flags Details
IE_Builds (61.23 KB, image/png)
2016-02-23 01:54 EST, yapei
no flags Details
IE_Deployments (62.51 KB, image/png)
2016-02-23 01:55 EST, yapei
no flags Details
IE11 Overview (664.38 KB, image/png)
2016-02-25 10:26 EST, Steve Goodwin
no flags Details
IE11 Build (664.38 KB, image/png)
2016-02-25 10:28 EST, Steve Goodwin
no flags Details
IE11 Overview (713.96 KB, image/png)
2016-02-25 10:29 EST, Steve Goodwin
no flags Details

  None (edit)
Description yapei 2016-02-03 01:25:17 EST
Created attachment 1120633 [details]
OverviewPage

Description of problem:
all pages(Overview page,secondary pages under Browse and Settings pages)for one project didn't adjust its size to fit with browser on IE11 and Edge25, some content are missing and some button are pushed to the left 


Version-Release number of selected component (if applicable):
devenv-rhel7_3313
IE11.65.10586.0
Edge25

How reproducible:
Always

Steps to Reproduce:
1. Create application on web console
2. Check all pages for this project

Actual results:
2. pages didn't display well, check attachment for details

Expected results:
2. pages should display correctly

Additional info:
Comment 1 yapei 2016-02-03 01:25 EST
Created attachment 1120634 [details]
TableLength
Comment 2 yapei 2016-02-03 01:30 EST
Created attachment 1120636 [details]
BuildConfigurationTab
Comment 3 yapei 2016-02-03 01:31 EST
Created attachment 1120637 [details]
BuildEnvironment
Comment 4 Robb Hamilton 2016-02-03 15:42:32 EST
Hi, Ya.

I am unable to reproduce this bug using either IE 11 or Edge 20 using my local environment running https://github.com/openshift/origin/commit/be9c5644618f0969264c693e0d957bd3494c109d. Any tips on reproducing?

Thanks,
Robb.
Comment 5 Robb Hamilton 2016-02-03 15:43 EST
Created attachment 1120899 [details]
Edge 20 showing Events page
Comment 6 yapei 2016-02-03 21:27:30 EST
(In reply to Robb Hamilton from comment #5)
> Created attachment 1120899 [details]
> Edge 20 showing Events page

what about IE11, any screen shot? Tried on devenv-rhel7_3325 today, Edge 25 display well, but IE11 still has the issue.
Comment 7 Robb Hamilton 2016-02-04 10:42:32 EST
Well, in going to get an IE11 screenshot for you, I've discovered this bug is intermittent (some times I can reproduce it, some times not).  I'm still digging in to it to see if I can figure out why it's occurring.  Resizing the IE11 window fixes the rendering issue, but refreshing the browser window recreates the bug.  :/
Comment 8 Robb Hamilton 2016-02-04 13:10:40 EST
Best I can tell, this bug is only occurring when the table height exceeds the available vertical space **once angular has finished loading data**.  In other words, this bug occurs when angular manipulates the DOM to insert the rows and the viewport isn't tall enough to accommodate all of the rows.  No ideas yet on possible fixes.
Comment 9 yapei 2016-02-05 05:23:04 EST
since this doesn't block any functionality, change to low priority and severity, we may develop more thoughts on checking and solving.
Comment 10 yapei 2016-02-23 01:48:37 EST
maybe should consider this as medium priority now in our full functional testing
Comment 11 yapei 2016-02-23 01:54 EST
Created attachment 1129628 [details]
IE_Builds
Comment 12 yapei 2016-02-23 01:55 EST
Created attachment 1129629 [details]
IE_Deployments
Comment 13 Steve Goodwin 2016-02-25 10:24:59 EST
Please retest. I believe it's been fixed or else I'm unable to reproduce. Attaching screenshots.
Comment 14 Steve Goodwin 2016-02-25 10:26 EST
Created attachment 1130584 [details]
IE11 Overview
Comment 15 Steve Goodwin 2016-02-25 10:28 EST
Created attachment 1130586 [details]
IE11 Build
Comment 16 Steve Goodwin 2016-02-25 10:29 EST
Created attachment 1130587 [details]
IE11 Overview
Comment 17 yapei 2016-02-26 00:43:06 EST
checked on devenv-rhel7_3540, issue was fixed
move to VERIFIED

Note You need to log in before you can comment on or make changes to this bug.