Bug 130429 - RFE: reduce rpmdb package size, add signatures/pubkeys, manage on client
Summary: RFE: reduce rpmdb package size, add signatures/pubkeys, manage on client
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmdb-redhat (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-20 14:37 UTC by Jeff Johnson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 04:38:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Johnson 2004-08-20 14:37:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
The rpmdb-* package is created (and hence downloaded) daily.

The size of rpmdb-* can be reduced significantly by
   a) including only Packages in %files
   b) doing --rebuilddb --dbpath /wherever in %post
   c) reducing the number of indices that are generated
      by --rebuilddb (Providenames and Basenames are
      of most use) in order to speed up --rebuilddb

Add --define '%_dbi_tags Packages:Providenames:Basenames'
to generate only the Providenames and Basenames indices.

Add %ghost to establish clean erasures for the indices, and %attr
to establish owner.group.

Add a cron script and ignore --rebuilddb failures if you
are worried about %post failures. The cron script should
attempt to clean up any/all .../*rebuilddb.123456 directories
from previous --rebuilddb failures as well.

Please also remember to do --justdb on signed packages, and
to import the public keys used for signing, when producing
the rpmdb-* package(s).

A daily patch-like delta rpmdb-* update to add/delete/modify
header entries on the client rpmdb for only the headers that
have changed is also quite doable, but I'll leave that for a
later bugzilla. In fact, headers could be delivered directly
to either up2date/yum caches, and then installed into
the rpmdb-* from %post and/or cron. Careful: yum/up2date
have slightly different headers than what is stored in
and rpmdb, rpmdb headers have appended signature tags
and prepended magic.

    

Additional info:

Upon request.

Comment 1 Jeff Johnson 2004-08-20 14:56:13 UTC
Ah, Pubkeys is useful too:
   --define '%_dbi_tags Packages:Providenames:Basenames:Pubkeys'

Comment 2 Jeff Johnson 2004-08-20 15:02:28 UTC
And a correction, rpmdb headers do not have magic, magic used
iff header is written to disk was what was originally intended.


Comment 3 Elliot Lee 2005-03-22 04:38:07 UTC
rpmdb is dead dead dead. :)


Note You need to log in before you can comment on or make changes to this bug.