Bug 1304338 - Patching status is not detected correctly from EAP7
Patching status is not detected correctly from EAP7
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7 (Show other bugs)
JON 3.3.5
Unspecified Unspecified
high Severity high
: DR01
: One-off release
Assigned To: Simeon Pinder
Jeeva Kandasamy
: Triaged
Depends On:
Blocks: 1314853
  Show dependency treegraph
 
Reported: 2016-02-03 05:57 EST by Michael Burman
Modified: 2016-06-06 14:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 14:56:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EAP6 (75.45 KB, image/png)
2016-03-03 13:58 EST, Matt Mahoney
no flags Details
EAP7 (73.41 KB, image/png)
2016-03-03 13:59 EST, Matt Mahoney
no flags Details
EAP7 (89.76 KB, image/png)
2016-03-23 16:26 EDT, Jeeva Kandasamy
no flags Details

  None (edit)
Description Michael Burman 2016-02-03 05:57:56 EST
Description of problem: The output generated by the EAP7 DMR differs when it comes to patching support, and instead of returning correct JSON like the EAP6:

 {
    "outcome" : "success",
    "result" : {
        "cumulative-patch-id" : "base",
        "patches" : [],
        "version" : "6.4.0.GA",
        "addon" : null,
        "layer" : {"base" : {
            "cumulative-patch-id" : "base",
            "patches" : []
        }}
    }
}

We only get the following output:

Version:             7.0.0.GA 
Cumulative patch ID: base     
One-off patches:     none

I have no idea if this is intended change or not.


Version-Release number of selected component (if applicable): JON 3.3.5 / EAP7 ER04


How reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michael Burman 2016-02-12 02:30:23 EST
The output with --json-output (which can't be used with EAP6) is a bit different to the old one.

[standalone@localhost:9990 /] patch info --json-output
{
    "outcome" : "success",
    "result" : {
        "cumulative-patch-id" : "base",
        "patches" : [],
        "version" : "7.0.0.GA",
        "addon" : null,
        "layer" : {"base" : {
            "cumulative-patch-id" : "base",
            "patches" : []
        }},
        "patch-stream" : {"JBoss EAP" : {
            "cumulative-patch-id" : "base",
            "patches" : [],
            "version" : "7.0.0.GA",
            "addon" : null,
            "layer" : {"base" : {
                "cumulative-patch-id" : "base",
                "patches" : []
            }}
        }}
    }
}
[standalone@localhost:9990 /]
Comment 2 Michael Burman 2016-02-12 06:24:09 EST
Fixed in the master (does not add support for patch-stream part):

commit 35c9504dd73e9b56c4cbcf10d2d5101678b35d3a
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Feb 12 13:23:03 2016 +0200

    [BZ 1304338] Use --json-output in patch info when dealing with EAP7 server
Comment 3 Simeon Pinder 2016-02-19 10:35:23 EST
Available for test in the following build:
http://jon01.mw.lab.eng.bos.redhat.com:8042/dist/release/jon/plugins/eap/3.3/Update-03/DR01/
Comment 4 Michael Burman 2016-03-03 10:52:00 EST
Previous commit is superseded by the master commit:

commit b57684bf616bad1444735ceced9f764b99318d72
Author: Michael Burman <miburman@redhat.com>
Date:   Thu Mar 3 17:21:56 2016 +0200

    [BZ 1314385] Initial implementation of wfly-10 plugin (copy of jboss-as-7 plugin)
Comment 5 Matt Mahoney 2016-03-03 13:58 EST
Created attachment 1132896 [details]
EAP6
Comment 6 Matt Mahoney 2016-03-03 13:59 EST
Created attachment 1132897 [details]
EAP7
Comment 10 Jeeva Kandasamy 2016-03-23 16:26 EDT
Created attachment 1139746 [details]
EAP7

EAP 7 with Application Platform Plug-in Pack Update-03 DR01

Note You need to log in before you can comment on or make changes to this bug.