Bug 13044 - FHS breaks current server during upgrade.
FHS breaks current server during upgrade.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-26 06:50 EDT by Henri Schlereth
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-03 04:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2000-06-26 06:50:02 EDT
Upgrading apache puts cgi-bin,html and icons in its new home in
/var/www, however the httpd.conf still points to /home/httpd which
has its index.html wiped out and manual directory cleared out but
not removed. Likely because I had piranha in there as well. At a 
production level machine that would knock out the web server by removing
the index.html and any custom directories such as piranha, htdig and so
on.

I have no objections to moving but I know for a fact that if you have
mod_frontpage installed this would cause chaos for FP98 clients and
server extensions, poor feeble minded programs that they are with all
their _vti stuff.

At this point, wouldnt it be better to leave and index.html in there
telling people that they need to relocate their non-default nifty
customized web page to var/www or do some sort of blanket move of the
contents with a re-direct (equally a stop gap).

This would work with a out of box install once the httpd.conf is fixed
but I can hear the howls on a upgrade.
Comment 1 Nalin Dahyabhai 2000-07-03 04:10:05 EDT
The package's %post now only changes the document root, which should alleviate
part of the problem.  There's not much we can do about existing data, though.
Comment 2 Nalin Dahyabhai 2000-07-10 15:09:37 EDT
It's not possible to migrate things correctly given that the /home/httpd/html
tree may
be too large to fit into /var (or vice-versa), so no modifications will be made
to httpd.conf
on upgrades.  The old configuration file will be saved and can be reused if the
icons
and manuals are copied from the new location to their old locations.

Note You need to log in before you can comment on or make changes to this bug.