This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1304403 - [RFE] Speed up RHEV deployment by installing engine and host(s) OSes at the same time
[RFE] Speed up RHEV deployment by installing engine and host(s) OSes at the s...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.1
Assigned To: Fabian von Feilitzsch
Tasos Papaioannou
Dan Macpherson
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 09:04 EST by Antonin Pagac
Modified: 2017-02-27 20:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-27 20:37:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2016-02-03 09:04:51 EST
Description of problem:
As of now, the OS installs first on host(s), then on engine. I understand this is because there is no good mechanism of controlling the timing of puppet run. It would however significantly reduce the deployment time if we were able to install OSes at the same time.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Fabian von Feilitzsch 2016-10-11 15:23:29 EDT
This went in with the ansible changes here: https://github.com/fusor/fusor/pull/1241

The engine all hypervisors should now provision in parallel.
Comment 3 Tasos Papaioannou 2016-10-24 11:37:26 EDT
Verified on QCI-1.1-RHEL-7-20161013.t.0.

Deployment log shows RHV hosts/engine kickstarting simultaneously, for both engine+hypervisor and self-hosted:

****
I, [2016-10-24T10:44:53.477947 #19444] INFO -- : Waiting for host mac5254004ca408.example.com's deployment to complete...

I, [2016-10-24T10:44:53.506977 #19444] INFO -- : Waiting for host mac525400dfb8e4.example.com's deployment to complete...
****
Comment 6 errata-xmlrpc 2017-02-27 20:37:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335

Note You need to log in before you can comment on or make changes to this bug.