Bug 1304411 - Automate "name" columns inappropriately sized
Automate "name" columns inappropriately sized
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Eric Winchell
Milan Falešník
:
: 1304408 1304410 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 09:24 EST by Krain Arnold
Modified: 2017-03-16 06:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:35:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested screenshot (186.99 KB, image/png)
2016-02-04 05:10 EST, Krain Arnold
no flags Details

  None (edit)
Description Krain Arnold 2016-02-03 09:24:05 EST
Description of problem:
In state machines, the column sizes are no longer adjustable. The user should either be able to re-size, or the column width should allow for adequate readability. 




How reproducible:
100%

Steps to Reproduce:
1. Navigate to ManageIQ → Infrastructure → VM → Provisioning → StateMachines → VMProvision_VM → Provision VM from Template (template)
2. Observe the information in the columns, particularly the name column


Actual results:
Column names look something like this:
Acqu
ireMA
CAddress

Expected results:
Column names should look like this:
AcquireMACAddress
Comment 2 Krain Arnold 2016-02-03 09:36:47 EST
*** Bug 1304410 has been marked as a duplicate of this bug. ***
Comment 3 Krain Arnold 2016-02-03 09:37:19 EST
*** Bug 1304408 has been marked as a duplicate of this bug. ***
Comment 5 Krain Arnold 2016-02-04 05:10 EST
Created attachment 1121058 [details]
requested screenshot

Dan, requested screenshot attached.
Comment 7 CFME Bot 2016-04-29 18:01:00 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/bbce0ea996549feb1c609a772be99fa3e1ab0d47

commit bbce0ea996549feb1c609a772be99fa3e1ab0d47
Author:     Eric Winchell <ewinchel@redhat.com>
AuthorDate: Wed Apr 27 15:16:38 2016 -0400
Commit:     Eric Winchell <ewinchel@redhat.com>
CommitDate: Wed Apr 27 15:16:38 2016 -0400

    fix Automate "name" column wrapping
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304411

 app/views/miq_ae_class/_class_fields.html.haml    | 14 ++++----------
 app/views/miq_ae_class/_instance_fields.html.haml | 14 ++++----------
 app/views/miq_ae_class/_instance_form.html.haml   | 14 ++++----------
 3 files changed, 12 insertions(+), 30 deletions(-)
Comment 8 Milan Falešník 2016-05-09 04:56:23 EDT
Verified in 5.6.0.5-beta2.4, the Name column is now sized enough to take the names of the mentioned rows.
Comment 11 errata-xmlrpc 2016-06-29 11:35:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.