Bug 1304431 - sub check box inconsistent when editing class schema
sub check box inconsistent when editing class schema
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.6.0
Assigned To: Zita Nemeckova
Dmitry Misharov
automate:ui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 10:12 EST by Krain Arnold
Modified: 2016-07-27 02:57 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:35:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krain Arnold 2016-02-03 10:12:56 EST
Description of problem:
When editing a class schema, the "sub" box is checked as default. When the new field is added, however, the box is unchecked. 

How reproducible:
100%

Steps to Reproduce:
1.Edit a Class schema
2.fill in required fields and do not change the default (checked)
3.Add the new field

Actual results:
The box is mysteriously unchecked

Expected results:
A checked Box

Additional info:
If you uncheck the box, check it again, and then save, the box is saved as checked.
Comment 1 Krain Arnold 2016-02-03 10:17:56 EST
After further review, if you save the schema and then edit it again, the sub box will appear as checked. So it seems that this is purely a Web UI error that is visible during the editing session.
Comment 5 CFME Bot 2016-03-17 10:05:55 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/6bf637e277baa0bde465e79c6d55c924ed07d3b1

commit 6bf637e277baa0bde465e79c6d55c924ed07d3b1
Author:     Zita Nemeckova <znemecko@redhat.com>
AuthorDate: Mon Mar 14 17:24:41 2016 +0100
Commit:     Zita Nemeckova <znemecko@redhat.com>
CommitDate: Tue Mar 15 12:59:36 2016 +0100

    BZ1304431 - sub checkbox inconsistent in class schema
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304431

 app/assets/javascripts/miq_ujs_bindings.js | 4 ++--
 app/controllers/miq_ae_class_controller.rb | 3 ++-
 2 files changed, 4 insertions(+), 3 deletions(-)
Comment 7 Dmitry Misharov 2016-04-18 06:56:17 EDT
Verified fixed in 5.6.0.1-beta2.20160413141124_e25ac0e. Checkbox keeps its state when the new field is added.
Comment 9 errata-xmlrpc 2016-06-29 11:35:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.