Bug 1304455 - Do not use lttng in rados/rbd by default
Do not use lttng in rados/rbd by default
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD (Show other bugs)
1.3.2
x86_64 Linux
unspecified Severity medium
: rc
: 1.3.2
Assigned To: Boris Ranto
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 11:34 EST by Tanay Ganguly
Modified: 2017-07-30 11:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHEL: ceph-0.94.5-7.el7cp Ubuntu: ceph_0.94.5-5redhat1trusty
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:46:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tanay Ganguly 2016-02-03 11:34:51 EST
Description of problem:
Continuously getting the Error message in vm.log file from qemu/kvm

libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886) 

Version-Release number of selected component (if applicable):
rpm -qa |grep ceph
ceph-common-0.94.5-4.el7cp.x86_64
ceph-osd-0.94.5-4.el7cp.x86_64
ceph-0.94.5-4.el7cp.x86_64
ceph-radosgw-0.94.5-4.el7cp.x86_64
ceph-debuginfo-0.94.5-4.el7cp.x86_64
ceph-selinux-0.94.5-4.el7cp.x86_64

selinux:
Loaded policy name:             targeted

How reproducible:
Always

Steps to Reproduce:
1. Create a RBD image, take snap and clone it.
2. Attach the same image in Qemu.
3. Create a VM on top of that RBD clone image.
4. Do some write operations of that image.

Actual results:
Seeing lots of Error in log message of the VM

Expected results:
There should not be any Error log message.

Additional info:


libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
Comment 2 Boris Ranto 2016-02-03 11:44:12 EST
We need to backport the following upstream PR (or rebase to 0.94.6):

https://github.com/ceph/ceph/pull/6415
Comment 3 Ken Dreyer (Red Hat) 2016-02-03 13:30:10 EST
Boris is right, we need https://github.com/ceph/ceph/pull/6415
Comment 4 Boris Ranto 2016-02-03 15:50:38 EST
dist-git commits related to build ceph-0.94.5-6.el7cp:
http://pkgs.devel.redhat.com/cgit/rpms/ceph/commit/?h=ceph-1.3-rhel-7&id=d81b7992d9797fd5138256828875a93c40400d3a
Comment 5 Boris Ranto 2016-02-03 17:02:45 EST
The package was successfully built in brew:

https://brewweb.devel.redhat.com/taskinfo?taskID=10437793
Comment 6 Ken Dreyer (Red Hat) 2016-02-03 17:50:25 EST
Needs adjustment to remove this conditional:

# LTTng-UST enabled on Fedora, RHEL 6, and SLES 12
%if 0%{?fedora} || 0%{?rhel} == 6 || 0%{?suse_version} == 1315
%global _with_lttng 1
%endif

The reason that upstream has this code is because lttng is not in EPEL 7. lttng is present in Red Hat Ceph Storage.
Comment 7 Boris Ranto 2016-02-03 17:51:45 EST
dist-git commits related to build ceph-0.94.5-7.el7cp:
http://pkgs.devel.redhat.com/cgit/rpms/ceph/commit/?h=ceph-1.3-rhel-7&id=c3392557e63a072b6a6cebbe2b9a0754c9dc561c
Comment 9 Tanay Ganguly 2016-02-08 03:53:02 EST
Marking it verified.

As i do not see any further error logs from my VM.log

libust[121880/121886]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
Comment 11 errata-xmlrpc 2016-02-29 09:46:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0313

Note You need to log in before you can comment on or make changes to this bug.