Bug 130448 - cannot define cups-based remote printer in text version
cannot define cups-based remote printer in text version
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 12:17 EDT by Mitch Krell
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-02 12:54:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitch Krell 2004-08-20 12:17:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
Since you can configure a remote cups-based printer in the gui, this
feature should also be available in the text version.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.3.19-1

How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-printer-tui
2.under type there is no entry for a cups-based remote printer
3.
    

Actual Results:  Can't be done

Expected Results:  Should have found an entry for remote cups-based
printer

Additional info:

I consider this important because it makes it nearly impossible to
define a remote cups-based printer for systems which are text-based only.
Comment 1 Tim Waugh 2004-08-24 09:41:02 EDT
It is possible, using foomatic-configure and lpadmin.

For remote IPP printers isn't it sufficient in most situations to use
CUPS' browsing facility?
Comment 2 Mitch Krell 2004-10-29 12:37:21 EDT
Tim,
  I have tried everything here to do this (I even tried in using the
RHEL4 beta) and don't seem to be able to configure a remote cups
printer using lpadmin and foomatic-configure. The documentation shows
how to configure remote printers for lpd, samba, ncp, and jetdirect
cards. but doesn't show how to configure a remote cups printer
(without making it lpd compatible). This is why I would like to
revisit this issue, or can you show me how to use foomatic-configure
with a remote cups printer.

Thanks.
Comment 3 Tim Waugh 2004-12-02 12:54:37 EST
Use "foomatic-configure -X -p PRINTER -d DRIVER" to create the PPD file (if you
don't already have one), put that in /usr/share/cups/model, then add the printer
using lpadmin or -- if you prefer -- using http://localhost:631/, either locally
or remotely.

I don't anticipate adding this functionality (or any other) to the text-mode
printconf tool in the near future.

Note You need to log in before you can comment on or make changes to this bug.