Bug 1304495 - bond slaves are not connected automatically after creation when device was disconnected manually
bond slaves are not connected automatically after creation when device was di...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity high
: rc
: 7.3
Assigned To: Bastien Nocera
Desktop QE
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 15:05 EST by Vladimir Benes
Modified: 2016-04-29 08:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-29 08:25:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2016-02-03 15:05:44 EST
Description of problem:
when bond is created with slaves these slaves are not upped. No other way how to up them. This looks like a regression to 7.1. 
There is no other way how to up them in control-center or in other gui application.

Version-Release number of selected component (if applicable):
NetworkManager-1.0.6-27.el7.x86_64
control-center-3.14.5-8.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.open control-center network
2.click plus and select bond
3.set ipv4 to manual and set ip
4.set ipv6 to ignore
5.add slave to ethernet device
6.save bond

Actual results:
bond connected but slave is not

Expected results:
both should be connected

Additional info:
Comment 2 Vladimir Benes 2016-02-03 15:49:33 EST
NOTABUG as master was upped by nmcli and this action removes slaves. Closing
Comment 3 Vladimir Benes 2016-02-05 05:47:12 EST
reopening just for reconsidering the situation when
1. the device for bond slave was disconnected by nmcli device disconnect 
2. the device is not grabbed by NM's autoconnect anymore as it's marked unsuitable for this because of device disconnect
3. do we want to connect it when the bond is created with slave profile?
Comment 4 Bastien Nocera 2016-04-29 08:25:20 EDT
Support for enterprise networking features will be removed in future versions of GNOME and of RHEL 7.x. We advise that you test Cockpit instead, which is better suited to manipulate enterprise networking feature.

Teaming support for Cockpit is tracked at:
https://github.com/cockpit-project/cockpit/issues/4330

Bonding, bridging and VLAN support are already implemented.

Note You need to log in before you can comment on or make changes to this bug.