Bug 1304586 - Could not create project and use the project
Could not create project and use the project
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Abhishek Gupta
yapei
: TestBlocker
Depends On:
Blocks: OSOPS_V3
  Show dependency treegraph
 
Reported: 2016-02-03 22:22 EST by Wei Sun
Modified: 2016-05-23 11:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-23 11:09:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2016-02-03 22:22:44 EST
Description of problem:
Log in web console.Sometimes the user could not create project successfully,sometimes after creating project successfully,but the user could not do anything in project,the console prompts "An error has occurred,The project could not be loaded."

Version-Release number of selected component (if applicable):
STG V3

How reproducible:
Always

Steps to Reproduce:
1.Create a project on web console
2.Create an application using existing project
3.

Actual results:
1.Template "project-request" is forbidden:namespace default does not exist
2.An error has occurred,The project could not be loaded

Expected results:
Could create the project and could create the application/build/deploy using existing the project on web console

Additional info:
Comment 1 Wei Sun 2016-02-04 22:37:31 EST
The bug is not only for console.
oc new-project yoxjz --config=ose_wsun@redhat.com.kubeconfig
Error from server: Template "project-request" is forbidden: namespace default does not exist
Comment 6 Wesley Hearn 2016-02-05 16:43:19 EST
We found the root cause.

In the process of when we re-generated the site certificates oadm overwrote one of the masters *.kubeconfig in /etc/origin/master causing the intermittent failures(round robin) We have opened another bug here https://bugzilla.redhat.com/show_bug.cgi?id=1305165 so that the command gets a bit more sanity checking around it.
Comment 7 Peter Ruan 2016-02-05 19:03:13 EST
verified that I can create a project now via web and CLI (automation).

Note You need to log in before you can comment on or make changes to this bug.