Bug 1304594 - Console -- Update Java dependency to 1.8
Console -- Update Java dependency to 1.8
Status: CLOSED ERRATA
Product: Red Hat Directory Server
Classification: Red Hat
Component: UI - General UI (Show other bugs)
10.0
Unspecified Unspecified
unspecified Severity unspecified
: DS10.1
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks: 1203710 1304595
  Show dependency treegraph
 
Reported: 2016-02-04 00:15 EST by Noriko Hosoi
Modified: 2016-11-07 10:39 EST (History)
1 user (show)

See Also:
Fixed In Version: redhat-ds-console-10.1.0-1.el7dsrv redhat-idm-console-10.1.0-1.el7dsrv redhat-admin-console-10.1.0-2.el7dsrv 389-ds-console-1.2.13-1.el7dsrv idm-console-framework-1.1.16-1.el7dsrv 389-admin-console-1.1.12-1.el7dsrv
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304595 (view as bug list)
Environment:
Last Closed: 2016-11-07 10:39:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Hosoi 2016-02-04 00:15:58 EST
Description of problem:

https://fedorahosted.org/released/javapackages/doc/
Packages that require minimal Java standard version can add versioned dependencies on one of virtual packages providing Java environment. For example if packages depending on functionality of JDK 8 can require java-headless >= 1:1.8.0.
Note 	
Epoch in versions of JVM packages

For compatibility with JPackage project packages providing Java 1.6.0 or later use epoch equal to 1. This was necessary because package java-1.5.0-ibm from JPackage project had epoch 1 for some reason, so packages providing other implementations of JVM also had to use non-zero epoch in order to keep version ordering correct.

Current dependency:
    Requires: java >= 1:1.6.0
    BuildRequires: java-devel >= 1:1.6.0
Comment 2 Viktor Ashirov 2016-09-13 09:34:28 EDT
On a fresh RHEL7.3 after redhat-ds was installed:

# rpm -q --whatprovides java
java-1.8.0-openjdk-1.8.0.102-3.b14.el7.x86_64

# rpm -q --whatrequires java
jss-4.2.6-42.el7.x86_64
idm-console-framework-1.1.16-2.el7dsrv.noarch
389-console-1.1.18-1.el7dsrv.noarch

Marking as VERIFIED.
Comment 4 errata-xmlrpc 2016-11-07 10:39:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2665.html

Note You need to log in before you can comment on or make changes to this bug.