Bug 130462 - Double clicking files on FAT in Nautilus doesn't work
Double clicking files on FAT in Nautilus doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC3Target 131589
  Show dependency treegraph
 
Reported: 2004-08-20 13:08 EDT by Daniel Malmgren
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 03:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2004-08-20 13:08:08 EDT
Description of problem:
When double clicking a file in Nautilus or right clicking and choosing
"open" nothing happens.

Version-Release number of selected component (if applicable):
2.7.x

How reproducible:
100%

Steps to Reproduce:
1. Double click a file (anything but a directory) in Nautilus
  
Actual results:
Nothing except a line in .xsession-errors:
/path/to/file: /path/to/file: cannot execute binary file

Expected results:
I expect Nautilus to to what I put in the settings

Additional info:
It's been like this since 2.6 -> 2.7 migration.
Right clicking files and choosing any of the "open with..."
alternatives works fine.
Comment 1 Alexander Larsson 2004-09-02 08:18:36 EDT
Does this still happen for you with latest rawhide?
There has been a lot of changes and fixes in this area.
Comment 2 Daniel Malmgren 2004-09-02 09:04:50 EDT
Yep. Exactly same result with latest of everything (nautilus 2.7.92-1).
Comment 3 Alexander Larsson 2004-09-06 09:27:03 EDT
Very strange. I don't see this at all. I wonder what the difference
with your system is.
Can you try creating a new user?
Comment 4 Daniel Malmgren 2004-09-06 09:36:29 EDT
I later found this in gnome bugzilla. It has with permissions to do.
If the execute-flag is set, nautilus tries to execute it instead of
looking at the mime type. (thing is, mostly when I double click
something, it is a movie, and I've got all of my movies on FAT32,
leaving me little control over permissions)

http://bugzilla.gnome.org/show_bug.cgi?id=151106
Comment 5 Alexander Larsson 2004-09-07 07:05:03 EDT
Ah, i see. That explains things. On FAT32 everything is +x.
Comment 6 Alexander Larsson 2004-09-07 09:47:22 EDT
I got this fixed. Patch waiting for release-team approval.
Comment 7 Daniel Malmgren 2004-09-07 09:55:28 EDT
Well, you can make things not +x (using umask in fstab), problem is
then it's for entire partition and then all directories are non
listable...
Comment 8 Alexander Larsson 2004-09-10 07:01:27 EDT
Fix is upstream.
Comment 9 Alexander Larsson 2004-09-14 03:44:31 EDT
gnome-vfs2 2.8.0 has fix.

Note You need to log in before you can comment on or make changes to this bug.