Bug 1304625 - Error while evaluating variable jboss_server_home
Error while evaluating variable jboss_server_home
Status: CLOSED DEFERRED
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid Designer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Barry LaFond
Matus Makovy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 03:43 EST by Hisanobu Okuda
Modified: 2016-02-08 08:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 06:26:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2777 Major Open Error while evaluating variable jboss_server_home 2016-02-10 11:13 EST

  None (edit)
Description Hisanobu Okuda 2016-02-04 03:43:29 EST
Description of problem:
Touching [server name]>Filesets, you get the following error:

An exception occurred invoking extension: org.jboss.ide.eclipse.archives.webtools.ui.extensions.filesets for object org.eclipse.jface.viewers.TreePath@d5aa6570


org.jboss.tools.foundation.core.expressions.ExpressionResolutionException: org.eclipse.core.runtime.CoreException: Error while evaluating variable jboss_server_home.
	at org.jboss.ide.eclipse.as.core.resolvers.RuntimeVariableResolver.resolve(RuntimeVariableResolver.java:77)
	at org.jboss.tools.foundation.core.expressions.ExpressionResolver.resolveVariable(ExpressionResolver.java:304)
	at org.jboss.tools.foundation.core.expressions.ExpressionResolver.resolve(ExpressionResolver.java:229)
	at org.jboss.ide.eclipse.archives.webtools.filesets.Fileset.getFolder(Fileset.java:71)
	at org.jboss.ide.eclipse.archives.webtools.filesets.Fileset.findPaths(Fileset.java:201)
	at org.jboss.ide.eclipse.archives.webtools.filesets.FilesetContentProvider.findPaths(FilesetContentProvider.java:235)
	at org.jboss.ide.eclipse.archives.webtools.filesets.FilesetContentProvider.getChildren(FilesetContentProvider.java:175)
	at org.jboss.ide.eclipse.archives.webtools.filesets.FilesetContentProvider.hasChildren(FilesetContentProvider.java:203)
	at org.eclipse.ui.internal.navigator.extensions.SafeDelegateTreeContentProvider.hasChildren(SafeDelegateTreeContentProvider.java:110)
	at org.eclipse.ui.internal.navigator.NavigatorContentServiceContentProvider.callNormalHasChildren(NavigatorContentServiceContentProvider.java:430)
	at org.eclipse.ui.internal.navigator.NavigatorContentServiceContentProvider.access$4(NavigatorContentServiceContentProvider.java:425)
	at org.eclipse.ui.internal.navigator.NavigatorContentServiceContentProvider$3.run(NavigatorContentServiceContentProvider.java:395)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.ui.internal.navigator.NavigatorContentServiceContentProvider.hasChildren(NavigatorContentServiceContentProvider.java:381)
	at org.eclipse.ui.internal.navigator.NavigatorContentServiceContentProvider.hasChildren(NavigatorContentServiceContentProvider.java:422)
	at org.eclipse.jface.viewers.AbstractTreeViewer.isExpandable(AbstractTreeViewer.java:2133)
	at org.eclipse.jface.viewers.TreeViewer.isExpandable(TreeViewer.java:553)
	at org.eclipse.jface.viewers.AbstractTreeViewer.isExpandable(AbstractTreeViewer.java:2171)
	at org.eclipse.jface.viewers.AbstractTreeViewer.updatePlus(AbstractTreeViewer.java:2863)
	at org.eclipse.jface.viewers.TreeViewer.updatePlus(TreeViewer.java:804)
	at org.eclipse.jface.viewers.AbstractTreeViewer.createTreeItem(AbstractTreeViewer.java:844)
	at org.eclipse.jface.viewers.AbstractTreeViewer$1.run(AbstractTreeViewer.java:818)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
	at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:791)
	at org.eclipse.jface.viewers.TreeViewer.createChildren(TreeViewer.java:611)
	at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:762)
	at org.eclipse.jface.viewers.AbstractTreeViewer.handleTreeExpand(AbstractTreeViewer.java:1495)
	at org.eclipse.jface.viewers.TreeViewer.handleTreeExpand(TreeViewer.java:903)
	at org.eclipse.jface.viewers.AbstractTreeViewer$4.treeExpanded(AbstractTreeViewer.java:1507)
	at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:132)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4454)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1388)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1412)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1397)
	at org.eclipse.swt.widgets.Tree.gtk_test_expand_row(Tree.java:2084)
	at org.eclipse.swt.widgets.Widget.windowProc(Widget.java:2130)
	at org.eclipse.swt.widgets.Display.windowProc(Display.java:4674)
	at org.eclipse.swt.internal.gtk.OS._gtk_main_do_event(Native Method)
	at org.eclipse.swt.internal.gtk.OS.gtk_main_do_event(OS.java:9106)
	at org.eclipse.swt.widgets.Display.eventProc(Display.java:1253)
	at org.eclipse.swt.internal.gtk.OS._g_main_context_iteration(Native Method)
	at org.eclipse.swt.internal.gtk.OS.g_main_context_iteration(OS.java:2477)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3407)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:135)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
Caused by: org.eclipse.core.runtime.CoreException: Error while evaluating variable jboss_server_home.
	at org.eclipse.core.internal.variables.DynamicVariable.getValue(DynamicVariable.java:58)
	at org.eclipse.core.internal.variables.StringSubstitutionEngine.resolve(StringSubstitutionEngine.java:269)
	at org.eclipse.core.internal.variables.StringSubstitutionEngine.substitute(StringSubstitutionEngine.java:192)
	at org.eclipse.core.internal.variables.StringSubstitutionEngine.performStringSubstitution(StringSubstitutionEngine.java:87)
	at org.jboss.ide.eclipse.as.core.resolvers.RuntimeVariableResolver.resolve(RuntimeVariableResolver.java:74)
	... 65 more
Caused by: java.lang.NullPointerException
	at org.jboss.ide.eclipse.as.core.resolvers.ConfigNameResolver.handleServerHome(ConfigNameResolver.java:137)
	at org.jboss.ide.eclipse.as.core.resolvers.ConfigNameResolver.resolveValue(ConfigNameResolver.java:131)
	at org.jboss.ide.eclipse.as.core.resolvers.ConfigNameResolver.resolveValue(ConfigNameResolver.java:116)
	at org.eclipse.core.internal.variables.DynamicVariable.getValue(DynamicVariable.java:56)
	... 69 more


Version-Release number of selected component (if applicable):
JBDS 8.1.0
Teiid Designer 9.0.1


How reproducible:


Steps to Reproduce:
1. create a new teiid project
2. add a new server as follows:-
2-1. click No default server defined
2-2. click Next
2-3. check Remote
2-4. check Management Operations
2-5. check Server is externally managed...
2-6. uncheck Assign a runtime to this server
2-7. click Next
2-8. click Finish
3. set the password for admin
4. click Start the server button
5. click the server name > Filesets
6. click Error tab. Then you will find the error

Actual results:


Expected results:


Additional info:
Comment 1 Matus Makovy 2016-02-08 06:26:05 EST
I'll close this, since we are tracking issues for Teiid Designer in JIRA. I created new JIRA and attached it to this bug report (TEIIDDES-2777).

Note You need to log in before you can comment on or make changes to this bug.