Bug 1304626 - ltp ftruncate fails
ltp ftruncate fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel-aarch64 (Show other bugs)
7.3
aarch64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Whitehouse
Jeff Bastian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 03:47 EST by Bill Peck
Modified: 2016-11-03 18:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: kernel-aarch64-4.5.0-0.rc5.29.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 18:20:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2016-02-04 03:47:35 EST
Description of problem:

ltp-lite ftruncate fails on aarch64.

ftruncate04                    FAIL       2    
ftruncate04_64                 FAIL       2    

Version-Release number of selected component (if applicable):
4.5.0-0.rc2.25.el7

How reproducible:
everytime

Steps to Reproduce:
1. execute ltp-lite task from beaker

Additional info:
will provide beaker links in followup comment
Comment 3 Mark Langsdorf 2016-02-17 13:48:54 EST
appears to be related to the mandatory locking option

the command line below fails
sudo mount -o loop,mand test.img /mnt

the command lines below succeeds
sudo mount -o loop,nomand test.img /mnt
sudo mount -o loop test.img /mnt
Comment 4 Jan Stancek 2016-02-19 10:15:06 EST
Presumably because of this commit:
  commit 9e8925b67a809bb27ce4b7d352d67f25cf1d7fc5
  Author: Jeff Layton <jeff.layton@primarydata.com>
  Date:   Mon Nov 16 09:49:34 2015 -0500
    locks: Allow disabling mandatory locking at compile time

@@ -2677,6 +2685,8 @@ long do_mount(const char *dev_name, const char __user *dir_name,
                                   type_page, flags, data_page);
        if (!retval && !may_mount())
                retval = -EPERM;
+       if (!retval && (flags & MS_MANDLOCK) && !may_mandlock())
+               retval = -EPERM;


$ git tag --contains 9e8925b67a809bb27ce4b7d352d67f25cf1d7fc5
v4.5-rc1
v4.5-rc2
v4.5-rc3

This matches KT1 results, this test was working up to kernel-4.4.0-0.23.el7.

# grep MANDATORY /boot/config-4.5.0-0.rc4.28.el7.aarch64 
# CONFIG_MANDATORY_FILE_LOCKING is not set

Upstream defaults to 'y'.
Comment 8 errata-xmlrpc 2016-11-03 18:20:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2145.html

Note You need to log in before you can comment on or make changes to this bug.