Bug 1304630 - perl-Mojolicious pulls in perl(Test::More)
perl-Mojolicious pulls in perl(Test::More)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Mojolicious (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 03:56 EST by Ralf Corsepius
Modified: 2016-02-04 09:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 09:10:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Split out perl-Test-Mojo (Patch against git master) (1.70 KB, patch)
2016-02-04 04:32 EST, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Ralf Corsepius 2016-02-04 03:56:45 EST
Description of problem:
perl-Mojolicious pulls in perl(Test::More) and further perl(Test::*) modules as a run-time dependency.

As perl-Mojolicious is part of very long dep chains of fairly common other packages, this causes quite some amount runtime installation bloat, esp. on rawhide/f24

Version-Release number of selected component (if applicable):
perl-Mojolicious-6.42-1.fc24.noarch

Additional info:
I would suggest perl-Mojolicious to be split into 2 packages. I don't know if this will be easily achievable because upstream doesn't seem to care about separating Test:: deps.
Comment 1 Ralf Corsepius 2016-02-04 04:32 EST
Created attachment 1121051 [details]
Split out perl-Test-Mojo (Patch against git master)

I was wrong. Splitting out Test::Mojo is sufficient to get rid of these deps.

Unless you object, I am going to apply the patch.
Comment 2 Emmanuel Seyman 2016-02-04 07:46:23 EST
(In reply to Ralf Corsepius from comment #1)
> 
> Unless you object, I am going to apply the patch.

Go ahead, Ralf.
Comment 3 Ralf Corsepius 2016-02-04 09:10:49 EST
Thanks, patch applied to master and package rebuilt for rawhide.

Note You need to log in before you can comment on or make changes to this bug.