Bug 130465 - LTC10798-no LOOPCHANGEFD 32 bit emulation in rhel4
LTC10798-no LOOPCHANGEFD 32 bit emulation in rhel4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Ric Wheeler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 13:22 EDT by Alfred Poon
Modified: 2009-12-02 14:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 14:04:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output.txt (8.43 KB, text/plain)
2004-09-10 11:46 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Alfred Poon 2004-08-20 13:22:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040616

Description of problem:
Server is PPC64, currently has RHEL3 with 2.4.21-6.EL kernel.  Tried
to upgrade to RHEL4 alpha 4 using this CD images:

RHEL4-Alpha4-RC-re0722.0-ppc-as-disc1-ftp.iso
RHEL4-Alpha4-RC-re0722.0-ppc-as-disc2-ftp.iso
RHEL4-Alpha4-RC-re0722.0-ppc-as-disc3-ftp.iso
RHEL4-Alpha4-RC-re0722.0-ppc-as-disc4-ftp.iso

Bootted from disk 1 and the installation program checked that the CD
was fine.  Chose to upgrade "Red Hat Enterprise Linux AS 3 (sda3)" on
this screen:

   +----------------+ System to Upgrade +-----------------+
   |                                                      |
   | One or more existing Linux installations have been   |
   | found on your system.                                |
   |                                                      |
   | Please choose one to upgrade, or select 'Reinstall   |
   | System' to freshly install your system.              |
   |                                                      |
   |         Red Hat Enterprise Linux AS 3 (sda3)         |
   |         Reinstall System                             |
   |                                                      |
   |          +----+                   +------+           |
   |          | OK |                   | Back |           |
   |          +----+                   +------+           |
   |                                                      |
   |                                                      |
   +------------------------------------------------------+


Some messages about packages being updated appear.  Then this screen
pops up:

+------------+ Exception Occurred +-------------+
|                                               |
| An unhandled exception has occurred.        # |
| This is most likely a bug.  Please copy     # |
| the full text of this exception or save     # |
| the crash dump to a floppy then file a      # |
| detailed bug report against anaconda at     # |
| http://bugzilla.redhat.com/bugzilla/        # |
|                                             # |
| Traceback (most recent call last):          # |
|   File "/usr/bin/anaconda", line 1145, in   # |
| ?                                           # |
|     intf.run(id, dispatch, configFileData)  # |
|   File "/usr/lib/anaconda/text.py", line    # |
|                                               |
|    +----+        +------+       +-------+     |
|    | OK |        | Save |       | Debug |     |
|    +----+        +------+       +-------+     |
|                                               |
|                                               |
+-----------------------------------------------+


I chose to Debug and the following was printed:

3.3.4.1 was
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1145, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 486, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 701, in doPreInstall
    if method.systemMounted (id.fsset, instPath):
  File "/usr/lib/anaconda/image.py", line 200, in systemMounted
    isys.lochangefd("/tmp/loop", self.loopbackFile)
  File "/usr/lib/anaconda/isys.py", line 118, in lochangefd
    _isys.lochangefd(loop, targ)
SystemError: (22, 'Invalid argument')

> /usr/lib/anaconda/isys.py(121)lochangefd()
-> os.close(targ)
(Pdb)


I've also tried to reinstall rather than upgrade and the same problem
occurred.  Only now it's also formatted my /boot partition and I can
no longer access my old RHEL3 system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from CD 1
2.Choosing either to upgrade from RHEL3 OR to reinstall the system
will produce the same problem
    

Actual Results:  The same "Exception Occurred" message appears.

Expected Results:  Install should continue

Additional info:
Comment 1 David Woodhouse 2004-09-07 05:38:30 EDT
Fix is in upstream kernel and should also be in current RHEL4 beta kernel.
Comment 2 IBM Bug Proxy 2004-09-10 11:46:12 EDT
Created attachment 103691 [details]
output.txt
Comment 3 IBM Bug Proxy 2004-09-10 11:46:31 EDT
----- Additional Comments From alfredp@ca.ibm.com  2004-09-10 11:44 -------
 
output from lsvpd commands

I was unable to access the WebASM menu of the squadron.  But I got someone to
install lsvpd on the machine.  I ran the commands "lsvpd", "lscfg -v", and
"lsmcode -A".  But I'm still not sure which is the firmware level or if it's
even displayed at all.	I've put the results in the attached text file. 
Comment 4 David Woodhouse 2004-09-10 12:11:20 EDT
I suspect bugzilla confusion. Are these new additions really supposed
to be related to the LOOPCHANGEFD bug which I think is now fixed?
Comment 5 Alfred Poon 2004-09-10 13:19:08 EDT
No this is not related.  Sorry.  I created the attachment in the LTC 
bugzilla 10798, not knowing that the attachment would be created here 
also.
Comment 6 IBM Bug Proxy 2004-09-10 13:56:13 EDT
----- Additional Comments From salina@us.ibm.com  2004-09-10 13:55 -------
On my p630, lsvpd output shows
*FC ????????
*DS Platform Firmware
*RM 3R040602
*VK RS6K
*YL U0.1-P1/Y1
*FC ????????
*DS System Firmware
*RM RG040601_d76e10_sfw137
*VK RS6K
*YL U0.1-P1/Y2

not seeing something like that in your output. 
Comment 7 IBM Bug Proxy 2004-09-10 13:56:34 EDT
----- Additional Comments From salina@us.ibm.com  2004-09-10 13:56 -------
Alfred, thanks for all the info.

Mike, I am adding you to cc list.  Is there another lsvpd version we should be 
using to get the firmware level or is it under another tag ? 
Comment 8 IBM Bug Proxy 2004-09-10 14:31:09 EDT
----- Additional Comments From strosake@us.ibm.com  2004-09-10 14:29 -------
If you can telnet to the system's FSP, you can cat /etc/DriverName to retrieve
the firmware level.

If you are at lsvpd level 0.12.1-1, running "lsmcode -r -d sys0" should print
something along the lines of "sys0!system:SF220_043 (t) SF220_014 (p) SF220_043
(b)|service:11292004081881CF0681".  You can also retrieve the currently booted
firmware level from the OS with "cat
/proc/device-tree/openprom/ibm,fw-vernum_encoded".

Please let me know if lsmcode is not printing the FW level. 
Comment 9 IBM Bug Proxy 2004-09-10 14:46:26 EDT
----- Additional Comments From alfredp@ca.ibm.com  2004-09-10 14:46 -------
Nothing was displayed when I ran "lsmcode -r -d sys0" as root.  

However, "cat /proc/device-tree/openprom/ibm,fw-vernum_encoded" displayed the 
following:

SF220_006 
Comment 10 IBM Bug Proxy 2004-09-10 15:11:15 EDT
----- Additional Comments From strosake@us.ibm.com  2004-09-10 15:09 -------
My guess is that lsvpd is not printing the FW level because it is unable to
retrieve dynamic VPD.  What level (if any) of ppc64-utils is installed on the
system?  (rpm -q ppc64-utils)

SF220_006 looks like a really old FW level... that should certainly be updated. 
Comment 11 IBM Bug Proxy 2004-09-10 15:16:28 EDT
----- Additional Comments From alfredp@ca.ibm.com  2004-09-10 15:14 -------
The ppc64-utils level is:

ppc64-utils-0.9-0 
Comment 12 IBM Bug Proxy 2004-09-10 15:31:06 EDT
----- Additional Comments From salina@us.ibm.com  2004-09-10 15:29 -------
We have upgraded to 34C and we can't install RHEL 4 Beta 1.
That is why we have asked Alfred ( who managed to install tbe Beta 1 ) what FW 
level he is using. 
Comment 13 IBM Bug Proxy 2004-09-10 16:01:01 EDT
----- Additional Comments From strosake@us.ibm.com  2004-09-10 15:58 -------
FYI, you should see the system firmware level using lsmcode if you install
ppc64-utils 2.1-0... but you already got it from the device-tree, so I guess
it's just academic. 
Comment 14 IBM Bug Proxy 2004-09-19 23:50:58 EDT
----- Additional Comments From khoa@us.ibm.com  2004-09-19 23:51 EDT -------
I don't think this bug has been resolved yet, so I'd like to re-open this
bug report.  Thanks. 
Comment 15 David Woodhouse 2004-09-20 09:17:42 EDT
Can we fix the relationship between your bugzilla and this one please?

This bug (RH #130465) was about the absence of the LOOPCHANGEFD ioctl,
which is now believed to be fixed.
Comment 16 IBM Bug Proxy 2004-12-16 11:35:55 EST
----- Additional Comments From mranweil@us.ibm.com  2004-12-16 11:24 EDT -------
The mirroring on this bug is messed up, I think, David from RH's side noticed
that things seemed mixed up (and I can't tell - it's a mess).

But this bug hasn't been updated in months.  There's been a lot of installation
fixes.  The bug on RH is modified (thinks it's a different problem).

I'm closing this, if you still have problems installing, please open a new bug.
 Sounds like at least part of the problem went away anyways. 
Comment 17 IBM Bug Proxy 2005-06-14 16:18:47 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REJECTED                    |CLOSED




------- Additional Comments From salina@us.ibm.com  2005-06-14 16:13 EDT -------
closing old problem 
Comment 20 Don Howard 2009-12-02 14:04:27 EST
Closing this old bug that is in modified state.  If this bug has not been resolved, please reopen it with new information.

Note You need to log in before you can comment on or make changes to this bug.