Bug 1304650 - [RFE] - he-setup should wait for all services and the Engine VM to come up successful at the end of the setup
[RFE] - he-setup should wait for all services and the Engine VM to come up su...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.2.0
: 2.2.0
Assigned To: Ido Rosenzwig
Nikolai Sednev
: FutureFeature, Triaged
Depends On: 1502747
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 04:25 EST by Fabian Deutsch
Modified: 2017-12-20 05:49 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this release, the self-hosted engine deployment script waits for the Manager VM to power up before reporting that the deployment is complete. Now when the deployment is finished, you can connect to the Manager right away instead of waiting for the VM to power up.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:49:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nsednev: needinfo-
rule-engine: ovirt‑4.2+
gklein: testing_plan_complete-
ylavi: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
screencast-2017-09-17_15.42.41.mkv (6.33 MB, application/octet-stream)
2017-09-17 08:51 EDT, Nikolai Sednev
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 75656 master MERGED plugins: core: Check that engine vm is up at the end of the setup 2017-04-26 09:55 EDT
oVirt gerrit 82452 master MERGED plugins: core: engine vm liveliness check after deployment 2017-10-03 10:59 EDT

  None (edit)
Description Fabian Deutsch 2016-02-04 04:25:48 EST
Description of problem:
Currently hosted-engine-setup is just starting the services at the end of the setup. But this can lead to the false assumption that everything is working at that point in time.
In reality it takes a while until the services are started and the VM is up and finished booting.

At best he-setup should wait until the services have been started and the VM is up until it ends the setup.
Comment 1 Sandro Bonazzola 2016-05-02 05:53:30 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Yaniv Lavi 2016-05-23 09:16:02 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 3 Yaniv Lavi 2016-05-23 09:21:41 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 5 Nikolai Sednev 2017-09-17 08:50:41 EDT
After successful deployment of ovirt-hosted-engine-setup-2.2.0-0.0.master.20170913082146.git120d800.el7.centos.noarch, while using ovirt-engine-appliance-4.2-20170916.1.el7.centos.noarch, I've got HE-VM powering up and after a few seconds it transited to up and running, I still got to wait a few moments. 

HE-VM was not reported as up at the very moment of SHE deployment had finished.
Is this an expected result, e.g. "Feature: Wait for engine vm to power up at the end of Hosted Engine deployment"? 

Please see the screencast attached.
Comment 6 Nikolai Sednev 2017-09-17 08:51 EDT
Created attachment 1326956 [details]
screencast-2017-09-17_15.42.41.mkv
Comment 7 Red Hat Bugzilla Rules Engine 2017-09-19 07:20:57 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Nikolai Sednev 2017-10-18 10:59:52 EDT
Works for me on ovirt-hosted-engine-setup-2.2.0-0.0.master.20171016160008.git55723e8.el7.centos.noarch.
Moving to verified.
Comment 9 Nikolai Sednev 2017-10-18 11:09:08 EDT
See also reproduction screencast from https://drive.google.com/a/redhat.com/file/d/0B85BEaDBcF88YkZORExlVTMxZUk/view?usp=sharing
Comment 10 Sandro Bonazzola 2017-12-20 05:49:22 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.