Bug 1304665 - dolphin crashes while previewing png files
dolphin crashes while previewing png files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdebase (Show other bugs)
6.7
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 04:56 EST by Siteshwar Vashisht
Modified: 2016-05-10 15:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:37:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream patch (1.42 KB, patch)
2016-02-04 05:42 EST, Siteshwar Vashisht
no flags Details | Diff

  None (edit)
Description Siteshwar Vashisht 2016-02-04 04:56:44 EST
Description of problem:
dolphin crashes while previewing png files

Version-Release number of selected component (if applicable):
kdebase-4.3.4-6.el6.x86_64

How reproducible:
Sometimes

Steps to Reproduce:
1. Keep information panel visible in dolphin
2. Open a folder containing png files in dolphin


Actual results:
dolphin crashes with this stacktrace :

#0  0x0000003bfac0f65b in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:42
#1  0x0000003c09055735 in KCrash::defaultCrashHandler (sig=6) at /usr/src/debug/kdelibs-4.3.4/kdeui/util/kcrash.cpp:258
#2  <signal handler called>
#3  0x0000003bfa432625 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#4  0x0000003bfa433e05 in abort () at abort.c:92
#5  0x0000003bfbc67324 in g_assertion_message (domain=<value optimized out>, file=<value optimized out>, line=<value optimized out>, func=0x7f5897c0d5d0 "gst_pulsesink_change_state", message=
    0x1f19e20 "assertion failed: (pulsesink->mainloop == NULL)") at gtestutils.c:1358
#6  0x0000003bfbc678f0 in g_assertion_message_expr (domain=0x0, file=0x7f5897c0c0b1 "pulsesink.c", line=2314, func=0x7f5897c0d5d0 "gst_pulsesink_change_state", expr=<value optimized out>)
    at gtestutils.c:1369
#7  0x00007f5897c04eef in gst_pulsesink_change_state (element=0x1f16220 [GstPulseSink], transition=GST_STATE_CHANGE_NULL_TO_READY) at pulsesink.c:2314
#8  0x00007f5898f7c05c in gst_element_change_state (element=0x1f16220 [GstPulseSink], transition=<value optimized out>) at gstelement.c:2531
#9  0x00007f5898f7f5b8 in gst_element_set_state_func (element=0x1f16220 [GstPulseSink], state=<value optimized out>) at gstelement.c:2487
#10 0x00007f58992324f3 in Phonon::Gstreamer::DeviceManager::canOpenDevice (this=<value optimized out>, element=0x1f16220 [GstPulseSink]) at ../../../3rdparty/phonon/gstreamer/devicemanager.cpp:142
#11 0x00007f58992326e7 in Phonon::Gstreamer::DeviceManager::createAudioSink (this=0x1eac280, category=<value optimized out>) at ../../../3rdparty/phonon/gstreamer/devicemanager.cpp:185
#12 0x00007f5899232f3e in Phonon::Gstreamer::DeviceManager::updateDeviceList (this=0x1eac280) at ../../../3rdparty/phonon/gstreamer/devicemanager.cpp:323
#13 0x00007f5899233ace in Phonon::Gstreamer::DeviceManager::DeviceManager (this=0x1eac280, backend=<value optimized out>) at ../../../3rdparty/phonon/gstreamer/devicemanager.cpp:94
#14 0x00007f589923125d in Phonon::Gstreamer::Backend::Backend (this=0x1c72d00, parent=<value optimized out>) at ../../../3rdparty/phonon/gstreamer/backend.cpp:89
#15 0x00007f58992315f3 in qt_plugin_instance () at ../../../3rdparty/phonon/gstreamer/backend.cpp:36
#16 0x00007f5899b2c69a in Phonon::KdePlatformPlugin::createBackend (this=<value optimized out>, newService=<value optimized out>)
    at /usr/src/debug/kdebase-runtime-4.3.4/phonon/platform_kde/kdeplatformplugin.cpp:155
#17 0x00007f5899b2d13b in Phonon::KdePlatformPlugin::createBackend (this=0x1a4e590) at /usr/src/debug/kdebase-runtime-4.3.4/phonon/platform_kde/kdeplatformplugin.cpp:204
#18 0x0000003c0ca2c526 in Phonon::FactoryPrivate::createBackend (this=0x1a4c3a0) at ../3rdparty/phonon/phonon/factory.cpp:119
#19 0x0000003c0ca2e3ef in Phonon::Factory::backend (createWhenNull=<value optimized out>) at ../3rdparty/phonon/phonon/factory.cpp:443
#20 0x0000003c0ca2798b in Phonon::BackendCapabilities::isMimeTypeAvailable (mimeType=...) at ../3rdparty/phonon/phonon/backendcapabilities.cpp:66
#21 0x0000000000438557 in InformationPanel::updatePhononWidget (this=0x1971fc0) at /usr/src/debug/kdebase-4.3.4/apps/dolphin/src/panels/information/informationpanel.cpp:731
#22 0x0000000000438aa7 in InformationPanel::showMetaInfo (this=0x1971fc0) at /usr/src/debug/kdebase-4.3.4/apps/dolphin/src/panels/information/informationpanel.cpp:629
#23 0x000000000043968d in InformationPanel::showItemInfo (this=0x1971fc0) at /usr/src/debug/kdebase-4.3.4/apps/dolphin/src/panels/information/informationpanel.cpp:422
#24 0x0000000000439ef4 in InformationPanel::qt_metacall (this=0x1971fc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffc35d3bdb0)
    at /usr/src/debug/kdebase-4.3.4/x86_64-redhat-linux-gnu/apps/dolphin/src/informationpanel.moc:105
#25 0x0000003c0596a7df in QMetaObject::activate (sender=0x185bf40, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3293
#26 0x0000003c059669be in QObject::event (this=0x185bf40, e=0x7ffc35d3c500) at kernel/qobject.cpp:1212
#27 0x0000003c07daaa0c in QApplicationPrivate::notify_helper (this=0x1664840, receiver=0x185bf40, e=0x7ffc35d3c500) at kernel/qapplication.cpp:4303
#28 0x0000003c07db094b in QApplication::notify (this=<value optimized out>, receiver=0x185bf40, e=0x7ffc35d3c500) at kernel/qapplication.cpp:4186
#29 0x0000003c08ff81f6 in KApplication::notify (this=0x7ffc35d3c850, receiver=0x185bf40, event=0x7ffc35d3c500) at /usr/src/debug/kdelibs-4.3.4/kdeui/kernel/kapplication.cpp:302
#30 0x0000003c05957d0c in QCoreApplication::notifyInternal (this=0x7ffc35d3c850, receiver=0x185bf40, event=0x7ffc35d3c500) at kernel/qcoreapplication.cpp:704
#31 0x0000003c059804c2 in sendEvent (this=0x166eed0) at kernel/qcoreapplication.h:215
#32 QTimerInfoList::activateTimers (this=0x166eed0) at kernel/qeventdispatcher_unix.cpp:603
#33 0x0000003c0597d948 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#34 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#35 0x0000003bfbc40642 in g_main_dispatch (context=0x166dce0) at gmain.c:2441
#36 g_main_context_dispatch (context=0x166dce0) at gmain.c:3014
#37 0x0000003bfbc44c98 in g_main_context_iterate (context=0x166dce0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3092
#38 0x0000003bfbc44e4c in g_main_context_iteration (context=0x166dce0, may_block=1) at gmain.c:3155
#39 0x0000003c0597d613 in QEventDispatcherGlib::processEvents (this=0x163e240, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#40 0x0000003c07e49b5e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x0000003c05956752 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x0000003c05956a1c in QEventLoop::exec (this=0x7ffc35d3c7a0, flags=...) at kernel/qeventloop.cpp:201
#43 0x0000003c05958d09 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#44 0x0000000000435915 in main (argc=1, argv=0x7ffc35d3cd48) at /usr/src/debug/kdebase-4.3.4/apps/dolphin/src/main.cpp:94


Expected results:
dolphin should not crash.

Additional info:

This crash can be avoided by calling Phonon::BackendCapabilities::isMimeTypeAvailable(mimeType) only for audio and video mime types. This method should not be called for "image/png" mime type.

Upstream fix: https://quickgit.kde.org/?p=kde-baseapps.git&a=commit&h=2fb4419de053c43a0a70ffb21920db687fa87b6e
Comment 2 Siteshwar Vashisht 2016-02-04 05:42 EST
Created attachment 1121074 [details]
Upstream patch
Comment 6 Jan Grulich 2016-02-24 07:20:00 EST
Fixed in kdebase-4.3.4-10.el6.
Comment 11 errata-xmlrpc 2016-05-10 15:37:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0744.html

Note You need to log in before you can comment on or make changes to this bug.