Bug 1304679 - ccgo-0.3.6.4-16.fc24 FTBFS: sigc++/object.h: No such file or directory
ccgo-0.3.6.4-16.fc24 FTBFS: sigc++/object.h: No such file or directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ccgo (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 05:45 EST by Petr Pisar
Modified: 2016-02-04 08:43 EST (History)
1 user (show)

See Also:
Fixed In Version: ccgo-0.3.6.5-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 08:43:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gentoo 569528 None None None 2016-02-04 07:55 EST

  None (edit)
Description Petr Pisar 2016-02-04 05:45:01 EST
ccgo-0.3.6.4-16.fc24 fails to build in F24:

g++ -DHAVE_CONFIG_H -I. -I../.. -pthread -I/usr/include/gtkmm-2.4 -I/usr/lib64/gtkmm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/gtk-unix-print-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gdkmm-2.4 -I/usr/lib64/gdkmm-2.4/include -I/usr/include/giomm-2.4 -I/usr/lib64/giomm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib64/pangomm-1.4/include -I/usr/include/cairomm-1.0 -I/usr/lib64/cairomm-1.0/include -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/gconfmm-2.6 -I/usr/lib64/gconfmm-2.6/include -I/usr/include/glibmm-2.4 -I/usr/lib64/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include -I/usr/include/gconf/2 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include    -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic -c -o misc.o misc.cc
In file included from ../control.hh:24:0,
                 from parser.hh:51,
                 from misc.hh:24,
                 from misc.cc:22:
../connect.hh:24:27: fatal error: sigc++/object.h: No such file or directory
 #include <sigc++/object.h>
                           ^
compilation terminated.

That's caused by upgrading libsigc++20-devel from 2.4.1-3.fc23 to 2.6.0-1.fc23. The libsigc++20-devel removed /usr/include/sigc++-2.0/sigc++/object.h file.

Note You need to log in before you can comment on or make changes to this bug.