Bug 1304686 - Start self-heal and display correct heal info after replace brick
Summary: Start self-heal and display correct heal info after replace brick
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ashish Pandey
QA Contact: Bhaskarakiran
URL:
Whiteboard:
Depends On: 1254121 1278284
Blocks: 1258313 1305755
TreeView+ depends on / blocked
 
Reported: 2016-02-04 11:04 UTC by Ashish Pandey
Modified: 2016-11-23 23:11 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1278284
: 1305755 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:57:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Ashish Pandey 2016-02-04 11:08:09 UTC
Description of problem:

After replacing a brick in disperse volume, shd does not start healing the newly added brick (added by "replace-brick"  command). 
heal info would not display any entries to be healed which is incorrect information.

Full heal is required to be invoked manually to write data on newly added brick.


Version-Release number of selected component (if applicable):

[root@aspandey glusterfs]# gluster --version
glusterfs 3.8dev built on Aug 17 2015 13:13:53
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.


How reproducible:

100%

Steps to Reproduce:
1 - Create a 4+2 disperse volume
2 - Fuse mount this volume and write some data (dir/files/links) on mount point
3 - Replace a brick for this volume on server side.
4 - Execute "gluster v heal <vol name> info" - It displays 0 as entry
5 - Check newly added brick location  - No data is written on this brick.

Actual results:

Healing of data on new brick is not getting started as soon as we replace a brick.

Expected results:
Healing of data on new brick should be started as soon as we replace a brick.

Comment 2 Vijay Bellur 2016-02-04 11:18:08 UTC
REVIEW: http://review.gluster.org/13353 (cluster/ec: Automate heal for replace brick) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 3 Vijay Bellur 2016-02-05 06:57:21 UTC
REVIEW: http://review.gluster.org/13353 (cluster/ec: Automate heal for replace brick) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 4 Vijay Bellur 2016-02-08 09:20:35 UTC
REVIEW: http://review.gluster.org/13353 (cluster/ec: Automate heal for replace brick) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 5 Vijay Bellur 2016-02-08 10:22:23 UTC
REVIEW: http://review.gluster.org/13353 (cluster/ec: Automate heal for replace brick) posted (#4) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 6 Vijay Bellur 2016-02-09 07:20:47 UTC
COMMIT: http://review.gluster.org/13353 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 12fbcd22d80be9cdd7e60341a173741d1d00f711
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Thu Feb 4 12:07:36 2016 +0530

    cluster/ec: Automate heal for replace brick
    
    Problem:
    After a replace brick command, newly added
    brick does not contain data which existed
    on old brick.
    
    Solution:
    Do getxattr after initialization of all the
    bricks. This will trigger heal for brick root
    as soon as it finds the version mismatch on
    newly added brick.
    
    Removing tests from ec-new-entry.t which were
    required to simulate automation of heal after
    replace brick.
    
    Change-Id: I08e3dfa565374097f6c08856325ea77727437e11
    BUG: 1304686
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/13353
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 7 Mike McCune 2016-03-28 22:17:27 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 8 Niels de Vos 2016-06-16 13:57:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.