Bug 1304692 - hardcoded gsyncd path causes geo-replication to fail on non-redhat systems
hardcoded gsyncd path causes geo-replication to fail on non-redhat systems
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aravinda VK
: EasyFix, Triaged
Depends On: 1162905
Blocks: 1165140 1165142
  Show dependency treegraph
 
Reported: 2016-02-04 06:25 EST by Aravinda VK
Modified: 2016-04-19 03:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1162905
Environment:
Last Closed: 2016-03-22 04:15:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2016-02-04 06:25:09 EST
+++ This bug was initially created as a clone of Bug #1162905 +++

Description of problem:
Line 16 of geo-replication/src/peer_gsec_create.in has a hard coded path of ${exec_prefix}/libexec/glusterfs/gsyncd - ignoring the value of remote_gsyncd option in gsyncd.conf

atleast in Ubuntu, there is no libexec folder anywhere on the system and the ubuntu debs provided by semiosis installs gsyncd to /usr/lib/x86_64-linux-gnu/glusterfs/

this file has not changed in 3.5 or 3.6, so affects both releases.

The only way to get distributed geo-replication working is to symlink the path to the correct location.

Version-Release number of selected component (if applicable): 3.5.1, 3.5.2, 3.6.1


How to reproduce:

follow the distributed geo-replication docs at https://github.com/gluster/glusterfs/blob/master/doc/admin-guide/en-US/markdown/admin_distributed_geo_rep.md on a non-redhat system


Steps to Reproduce:
1. setup geo-replication as per docs
2. start the geo-replication
3. status never changes from "Not Active"
4. log files show cannot execute gsyncd

Actual results:

E [glusterd-geo-rep.c:2685:glusterd_gsync_read_frm_status] 0-: Unable to read gsyncd status file
E [glusterd-geo-rep.c:2999:glusterd_read_status_file] 0-: Unable to read the statusfile for /export/sitedata brick for  ds0(master), 10.42.0.8::geo-repl(slave) session


Expected results:

geo-replication to work.

Additional info:

https://github.com/gluster/glusterfs/blob/release-3.6/geo-replication/src/peer_gsec_create.in#L16

--- Additional comment from John Skeoch on 2015-03-22 21:06:59 EDT ---

User fharshav@redhat.com's account has been closed

--- Additional comment from Vijay Bellur on 2016-01-27 04:44:09 EST ---

REVIEW: http://review.gluster.org/13298 (geo-rep: Fix gsyncd prefix in gsec_create) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Aravinda VK on 2016-01-27 05:10:33 EST ---



--- Additional comment from Vijay Bellur on 2016-01-28 04:59:41 EST ---

REVIEW: http://review.gluster.org/13298 (geo-rep: Fix gsyncd prefix in gsec_create) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-04 06:16:30 EST ---

COMMIT: http://review.gluster.org/13298 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 453abcb821b712f849f91a2a370a4debff89eed2
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Jan 27 15:08:03 2016 +0530

    geo-rep: Fix gsyncd prefix in gsec_create
    
    gsec_create script is generated after running ./configure
    
    libexec dir was formed using $prefix/libexec, but in Debian based
    distributions libexec dir is not present, instead they use lib
    directory to store these scripts.
    
    With this patch, full libexec path is fetched during ./configure.
    
    BUG: 1162905
    Change-Id: I9f47a38e6ab0027c7df6716136fbe0635e95a593
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13298
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Raghavendra Talur <rtalur@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 1 Vijay Bellur 2016-02-04 06:26:27 EST
REVIEW: http://review.gluster.org/13354 (geo-rep: Fix gsyncd prefix in gsec_create) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2016-02-15 02:00:52 EST
REVIEW: http://review.gluster.org/13354 (geo-rep: Fix gsyncd prefix in gsec_create) posted (#2) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 3 Vijay Bellur 2016-02-17 07:49:01 EST
COMMIT: http://review.gluster.org/13354 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 3adeb0a15057b97fed75c293a1a85439dc235c31
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Jan 27 15:08:03 2016 +0530

    geo-rep: Fix gsyncd prefix in gsec_create
    
    gsec_create script is generated after running ./configure
    
    libexec dir was formed using $prefix/libexec, but in Debian based
    distributions libexec dir is not present, instead they use lib
    directory to store these scripts.
    
    With this patch, full libexec path is fetched during ./configure.
    
    BUG: 1304692
    Change-Id: I9f47a38e6ab0027c7df6716136fbe0635e95a593
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13298
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Raghavendra Talur <rtalur@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
     (cherry picked from commit 453abcb821b712f849f91a2a370a4debff89eed2)
    Reviewed-on: http://review.gluster.org/13354
Comment 4 Kaushal 2016-04-19 03:24:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.