Bug 1304698 - Unable tu save custom icon for VM
Unable tu save custom icon for VM
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3
All All
unspecified Severity high (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Lukas Svaty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 06:55 EST by Lukas Svaty
Modified: 2016-02-10 01:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 08:59:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2016-02-04 06:55:19 EST
Description of problem:
Saving custom icon for Vm in WA portal is blocked by engine with message: Operation Cancelled: Provided VM icon is of unknown type.

Version-Release number of selected component (if applicable):
rhevm-3.6.3-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Add any icon 150x120 to VM
2. Save

Actual results:
Provided VM icon is of unknown type.

Expected results:
Should succeed.

Additional info:
2016-02-04 12:54:01,070 WARN  [org.ovirt.engine.core.bll.UpdateVmCommand] (ajp-/127.0.0.1:8702-3) [50be8f28] CanDoAction of action 'UpdateVm' failed for user admin@internal. Reasons: VAR__ACTION__UPDATE,VAR__TYPE__VM,PROVIDED_VM_ICON_OF_UNKNOWN_TYPE
Comment 3 Lukas Svaty 2016-02-08 08:59:11 EST
Re-tested this on fresh installation of engine and I was unable to reproduce it. This seems to be some kind of misconfiguration of testing engine. If this problem re-appear please re-open this bug. For now CLOSEing.

Note You need to log in before you can comment on or make changes to this bug.