Bug 130470 - Headers/Footers don't print
Headers/Footers don't print
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 14:28 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 20:13:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-08-20 14:28:28 EDT
Description of problem:

  I have been looking for date/time, page numbers, etc. on the
header/footer of printed Mozilla pages, but they are all blank.

  The File->Page Setup-><tab>->Margins & Header/Footer shows all of
these good things selected, but nothing prints out.

Version-Release number of selected component (if applicable):

  Has been this way for months.

  I have version 1.7.2 of Mozilla

  The rest of my system is up2date.

How reproducible:

  Unfortunately - totally reproducible.

Steps to Reproduce:
1.  Scoot to a web page
2.  Check that File->Page Setup-><tab>->Margins & Header/Footer
parameters are set.
3.  Print
4.  Observe printed page for Headers/Footers
5.  :-(
  
Actual results:

  blank

Expected results:

  Header and Footers with useful information

Additional info:

  The Headers/Footers DO show on the File->Print Preview
Comment 1 Jay Smith 2004-09-20 01:17:59 EDT
You did not mention if you are using Xprint or if you are printing
through Mozilla's native postscript.

If you are using Xprint (or even if you are not), you should take a
look at http://www.jw-stumpel.nl/stestu.html#T9 for some ideas.

The missing headers problem could be related to the Xprint font issue
that is addressed/solved on the referenced web page.

I have also seen, but lost track of, a similar newsgroup posting to
yours.  Somebody suggested that the problem was that the page headers
were actually there, but that the print setup did not leave enough
page margin for them to fit it.  Unfortunately, I can't locate the
reference.  I seem to recall that the solution was to change the size
of the page margins, but I don't recall if this was in mozilla prefs
(perhaps the about:config, xprint, cups, or where.

I think your problem is known, it is just a matter of finding the
correct answer.

Jay
Comment 2 Bob Gustafson 2004-10-08 17:40:47 EDT
My HP_Laserjet 2100M printer does not print to the edge of an 8.5x11
piece of paper, but is a bit shy on both the vertical and horizontal
dimensions.

The Foomatic PPD for that printer apparently does not pick this up. I
have a HP .ppd file around here somewhere. Will substitute for/compare
with the foomatic to get to the bottom of this.

Problem appears to be not with Mozilla, but with printer (cups?) folks.

To be continued
Comment 3 Bob Gustafson 2004-10-08 20:13:44 EDT
OK, I put in the HP factory PPD file - it more than twice as big as
the generic foomatic file supplied with CUPS.

But, it did not make any difference - the Headers and Footers still
did not print out.

However, within Mozilla, if you click on 'Print...' and then click on
the button 'Properties...' in that dialog box, you will see 4 data
input boxes - each one for a different dimensional difference between
the paper size and the actual printing margin (top, bottom, left,
right). The number within each box is 0.04  This is too small.

From the PPD file, it seems as though there is a 12 point difference
between paper edge and printing image position. This is 12/72 inches,
so put the number 0.17 in the boxes.

[ Note that this dialog box is unique to Mozilla. It does not appear
in OpenOffice writer, or in Evolution calendar (the two other
applications I looked at - so it is a Mozilla problem ]

And - drum roll. We have Headers and Footers.

Works for me

Note You need to log in before you can comment on or make changes to this bug.