This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1304738 - unavailable NFS blocks KDE UI
unavailable NFS blocks KDE UI
Status: NEW
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-runtime (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
: 1063825 1421477 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 08:51 EST by Michael Petlan
Modified: 2017-06-30 02:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2912971 None None None 2017-02-13 06:31 EST

  None (edit)
Description Michael Petlan 2016-02-04 08:51:04 EST
Description of problem:

When some NFS mountpoints are mounted and a network problem happens, the KDE UI becomes unresponsive.

That happens probably when KDE (Konqueror? Panel? Widgets?) browses the files in the NFS-mounted directories. I don't know the structure of KDE, so I filed this bug against kde-runtime, and I believe you can figure out what's going on much easier than me, and redirect the bug to the correct component if necessary.


Version-Release number of selected component (if applicable):
kde-runtime-4.10.5-8.el7.x86_64

How reproducible:
often

Steps to Reproduce:
1. mount a NFS mountpoint
2. make it not responsive/available -- i.e. disconnect from the corporate VPN


Actual results:

The KDE panels get frozen, clock widget stops, the workspace widget does not react. Switching workspaces by keyboard shorttcuts work. Widgets on desktop stop showing CPU load, etc.


Expected results:

In my opinion:

1) I would like to prevent KDE to browse any NFS mountpoints. I do not use Konqueror for casual file operations, I sometimes use the Qt widgets for "open file", "save file", "save as", etc. I never access the NFS mountpoints within a GUI app. Is there any indexing being done? Could this indexing be limited only to some sub-trees?

2) However, it would be nice anyway if the UI could not be blocked by something in background that does some FS IO...

Additional info:
Comment 2 Jan Grulich 2016-02-15 03:43:13 EST
This is a well known issue and upstream resolution on this is that this would need to be fixed at a lower level and the only thing what could be probably done is to workaround this everywhere which is not a good solution. Btw. it's not only KDE which have a problem with unavailable NFS mounts.

See:
https://bugs.kde.org/show_bug.cgi?id=355292#c1
https://bugs.kde.org/show_bug.cgi?id=316655#c20
Comment 3 Michael Petlan 2016-02-15 08:06:34 EST
Yes, it it not only in KDE, I had similar problems with XFce Thunar, etc. The problem I see in KDE is that the services that access the NFS are not separated enough from the UI. I am not familiar with the internals, but I don't see a reason why a desktop switcher or panel clock should be blocked by some IO operation that has a fairly high chance to break and finally is not necessary for the functionality of the particular widgets.
Comment 4 Michael Petlan 2016-07-15 08:03:52 EDT
Hi Jan. I have a question... Is there any chance this issue gets fixed within a near future timeframe (e.g. 7.3)? It is a very annoying bug, especially, when you work remotely via VPN. You either cannot use NFS mountpoints or an unstable VPN/wifi/whatever stands in between breaks the NFS connection pretty often (several times in a day). Thus, if the GUI freezes due to that every time, the workstation becomes almost unusable.

This issue is very old, older than this bug, I am wondering whether I am the only one who suffers from it, or how the others solved/workaround-ed it...

I'd be willing to help fixing it, if there's any way to do so, but I don't know the KDE internals... However, I suppose there's some FS-indexing process, that regularly touches the NFS mountpoints. Am I right? Is that the cause? If yes, is there any way to get rid of it?

I don't want anything automated to touch the mounts. I use them only for manual file transfers by 'cp something /mnt/somewhere/'. There's no need for KDE to touch them at all.

Thank you in advance for any advices.
Comment 5 Jan Grulich 2016-09-27 05:22:55 EDT
Sorry, I'm not going to fix this anytime soon. As I said before, this would be substantial effort and should be fixed/solved at lower level.
Comment 6 Jan Grulich 2017-01-19 04:01:35 EST
*** Bug 1063825 has been marked as a duplicate of this bug. ***
Comment 7 Michael Petlan 2017-01-19 06:25:46 EST
(In reply to Jan Grulich from comment #5)
> Sorry, I'm not going to fix this anytime soon. As I said before, this would
> be substantial effort and should be fixed/solved at lower level.

Okey, so is there any way to workaround it? Am I right with the theory about the indexer which touches it? Can I disable that feature somehow? Could you please explain in few words what is going on and where can I disable the thing?

Thanks in advance.
Comment 8 Jan Grulich 2017-01-20 02:03:59 EST
You can disable the indexer in systemsettings, but I don't think it will solve your problem as I think there might be other places getting stuck on unavailable NFS mount.
Comment 9 Jan Grulich 2017-02-13 04:32:12 EST
*** Bug 1421477 has been marked as a duplicate of this bug. ***
Comment 13 Michael Petlan 2017-06-22 08:13:45 EDT
That is sad, especially if customers face this issue too. Anyway, I switched to Mate Desktop Environment and I am fine...

Note You need to log in before you can comment on or make changes to this bug.