Bug 1304743 - (TEIID-3950-DV6.2.3) UDFs aren't found when using old function definitions model
UDFs aren't found when using old function definitions model
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Compatibility (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: jolee
Andrej Smigala
:
Depends On:
Blocks: 1289142
  Show dependency treegraph
 
Reported: 2016-02-04 09:04 EST by dsteigne
Modified: 2016-08-24 07:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:49:24 EDT
Type: Support Patch
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample Model Project Set using old UDF functiondef model (84.09 KB, application/zip)
2016-02-04 09:04 EST, dsteigne
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3950 Major Resolved UDFs aren't found when using old function definitions model 2017-04-28 15:55 EDT
Red Hat Knowledge Base (Solution) 2140071 None None None 2016-02-04 09:07 EST

  None (edit)
Description dsteigne 2016-02-04 09:04:17 EST
Created attachment 1121109 [details]
Sample Model Project Set using old UDF functiondef model

Description of problem:
See https://issues.jboss.org/browse/TEIID-3950

When migrating an old VDB that contains the old functiondefinitions model the server sees it as a Function model[1] but the functions are not found [2]when you try to use them.

[1] [org.teiid.RUNTIME] (MSC service thread 1-7) Model udfTokenFunctions in VDB oldUDF skipped being loaded because of its type FUNCTION

[2] [org.teiid.PROCESSOR] (Worker0_QueryProcessorQueue10) org.teiid.api.exception.query.QueryResolverException: TEIID30068 The function 'getToken('125421', '?', 2)' is an unknown form. Check that the function name and number of arguments is correct. Sending error to client 1trCiU5AkzFn.5


Version-Release number of selected component (if applicable):
6.2.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 dsteigne 2016-02-04 09:17:07 EST
Tested each version and this works in 6.0 but doesn't in 6.1 and 6.2. According to Engineering the server should still recognize the old UDF models.
Comment 3 JBoss JIRA Server 2016-02-04 11:05:28 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3950 to Resolved
Comment 4 jolee 2016-02-11 12:50:18 EST
git@github.com:jboss-integration/teiid.git : 8.7.x-prod-ipv6.2 : 0cdbd6d

git@github.com:teiid/teiid.git : 62-8.7.x : 0cdbd6d

Note You need to log in before you can comment on or make changes to this bug.