Bug 1304773 - Unable to edit fence agents
Unable to edit fence agents
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.3
: 3.6.3.1
Assigned To: Alexander Wels
Petr Matyáš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 10:09 EST by Alexander Wels
Modified: 2016-02-18 06:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:10:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: exception+
rule-engine: planning_ack+
oourfali: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53072 None None None 2016-02-04 10:10 EST
oVirt gerrit 53094 ovirt-engine-3.6 MERGED webadmin: Edit Fence Agent 2016-02-04 10:52 EST
oVirt gerrit 53105 ovirt-engine-3.6.3 MERGED webadmin: Edit Fence Agent 2016-02-05 03:01 EST

  None (edit)
Description Alexander Wels 2016-02-04 10:09:06 EST
Description of problem:
When editing a fence agent without changing the management ip or type and clicking ok. The UI will highlight the management ip and type and indicate there is a duplicate fence agent.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Go to edit host with a host that has some fence agents configured.
2. Click one of the existing fence agents to open up the edit dialog.
3. Change something that is no the mangement ip and type (lets say options).
4. Click OK and you will see red boxes around the management IP/type and it won't allow you to save the changes.

Actual results:
See reproduction steps.

Expected results:
You can save changes to non mangement ip/type.

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2016-02-04 10:10:59 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-04 10:10:59 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Red Hat Bugzilla Rules Engine 2016-02-04 10:22:18 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 4 Red Hat Bugzilla Rules Engine 2016-02-04 11:02:51 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 5 Petr Matyáš 2016-02-10 09:30:29 EST
Verified on 3.6.3-2

Note You need to log in before you can comment on or make changes to this bug.