Bug 1304792 - Disks table - some columns are not sortable
Disks table - some columns are not sortable
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Eyal Shenitzky
Raz Tamir
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 10:55 EST by Pavel Stehlik
Modified: 2017-12-20 06:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:06:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: planning_ack+
rule-engine: devel_ack+
pnovotny: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81864 master MERGED frontend: Allow sort disks table by shareable 2017-09-19 05:47 EDT
oVirt gerrit 81866 master MERGED frontend: Allow sort disks table by Attach To 2017-09-19 05:47 EDT
oVirt gerrit 81867 master MERGED frontend: Allow sort disks table by Storage-domain 2017-09-19 05:48 EDT

  None (edit)
Description Pavel Stehlik 2016-02-04 10:55:22 EST
Description of problem:
 It's not possible to sort columns in tab Disks 'Attached to' and when option 'Images' is selected also column 'Storage Domain(s)' & 'Allocation Policy'. 
On 'Direct Lun' option there also almost all - please check! (serial, vendor, etc).
On 'Cinder' option only 'Storage Domain(s)' & 'Attached to' are affected.

Version-Release number of selected component (if applicable):
3.6.3-0.1.el6

How reproducible:
100%

Steps to Reproduce:
1. use the webadmin - Disks tab, try to click on table header 

Additional info:
no logs nor screenshot applicable.
Comment 1 Sandro Bonazzola 2016-05-02 06:08:08 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Yaniv Lavi 2016-05-23 09:22:38 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 3 Yaniv Lavi 2016-05-23 09:25:13 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Oved Ourfali 2017-06-21 08:49:28 EDT
Greg, is it different in the new design?
Is it a storage or UX issue?
Comment 5 Greg Sheremeta 2017-07-05 14:25:37 EDT
Still an issue, moving to storage
Comment 6 Raz Tamir 2017-09-24 03:51:50 EDT
Verified on ovirt-engine-4.2.0-0.0.master.20170921184504.gitfcfc9a7.el7.centos

All columns are sortable under Disk tab
Comment 7 Sandro Bonazzola 2017-12-20 06:06:34 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.