Bug 1304799 - Occasional build failure of tcl due to missing tclDTrace.h header
Occasional build failure of tcl due to missing tclDTrace.h header
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tcl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 11:12 EST by Sinny Kumari
Modified: 2016-03-29 15:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: tcl-8.6.5-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 15:34:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (606 bytes, patch)
2016-03-22 13:01 EDT, Jaroslav Škarvada
no flags Details | Diff
Proposed fix (12.43 KB, patch)
2016-03-22 16:47 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Sinny Kumari 2016-02-04 11:12:41 EST
Occasionally, tcl fails to build on one or more architecture in koji for rawhide with following error message:
In file included from /builddir/build/BUILD/tcl8.6.4/generic/tclTomMathInt.h:1:0,
                 from /builddir/build/BUILD/tcl8.6.4/generic/tommath.h:1,
                 from /builddir/build/BUILD/tcl8.6.4/libtommath/bn_fast_s_mp_mul_digs.c:1:
/builddir/build/BUILD/tcl8.6.4/generic/tclInt.h:3999:23: fatal error: tclDTrace.h: No such file or directory
 #include "tclDTrace.h"
                       ^
compilation terminated.

Complete build log message can be found at https://kojipkgs.fedoraproject.org//work/tasks/9642/12849642/build.log

From the error message it appears that problem is occurring because of doing parallel make and header tclDTrace.h was not generated before the use.
When I tried rebuilding tcl with just make, build was always successful.

Koji build link
---------------
Primary koji - http://koji.fedoraproject.org/koji/taskinfo?taskID=12849628
s390 koji - http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2066115

Version-Release number of selected component (if applicable): tcl-8.6.4-1.fc24
Comment 1 Jan Kurik 2016-02-24 09:24:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Jaroslav Škarvada 2016-03-22 12:55:03 EDT
Moving to rawhide
Comment 3 Jaroslav Škarvada 2016-03-22 13:00:33 EDT
This seems to be an issue with parallel make. I guess it should work with MAKEOPTS=-j1
Comment 4 Jaroslav Škarvada 2016-03-22 13:01 EDT
Created attachment 1139168 [details]
Proposed fix

This may be not enough.
Comment 5 Jaroslav Škarvada 2016-03-22 13:12:25 EDT
Upstream ticket:
https://core.tcl.tk/tcl/tktview/7d0db7c388f52de81faf12da332bc97a24f7b9e5
Comment 6 Jaroslav Škarvada 2016-03-22 16:47 EDT
Created attachment 1139231 [details]
Proposed fix
Comment 7 Fedora Update System 2016-03-22 18:01:53 EDT
tk-8.6.5-1.fc24 tcl-8.6.5-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-87ea655bd9
Comment 8 Fedora Update System 2016-03-23 15:56:28 EDT
tcl-8.6.5-1.fc24, tk-8.6.5-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-87ea655bd9
Comment 9 Fedora Update System 2016-03-29 15:34:45 EDT
tcl-8.6.5-1.fc24, tk-8.6.5-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.