Bug 1304826 - rhel-osp-director: Failed to deploy 7.3 with externl ceph: Error: Could not find data item ceph_mon_initial_members in any Hiera data file and no default supplied..."
rhel-osp-director: Failed to deploy 7.3 with externl ceph: Error: Could not f...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: y3
: 7.0 (Kilo)
Assigned To: Giulio Fidente
Alexander Chuzhoy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 12:38 EST by Alexander Chuzhoy
Modified: 2016-02-18 11:52 EST (History)
13 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.6-121.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:52:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2016-02-04 12:38:26 EST
rhel-osp-director: Failed to deploy 7.3 with externl ceph
Error: Could not find data item ceph_mon_initial_members in any Hiera data file and no default supplied at /var/lib/heat-config/heat-config-puppet/f104b1dd-0c5f-4aae-84a4-d8335c81574f.pp:48 on node overcloud-compute-1.localdomain

Environment:
instack-undercloud-2.1.2-37.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-112.el7ost.noarch

Steps to reproduce:
Attempt to deploy overcloud with external ceph using this command:
export THT=/usr/share/openstack-tripleo-heat-templates
openstack overcloud deploy --templates $THT \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/storage-environment.yaml \
-e /home/stack/network-environment.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml \
-e /home/stack/post.yaml \
-e /home/stack/enable-tls.yaml \
-e /home/stack/inject-trust-anchor.yaml \
-e /home/stack/post.yaml \
--control-scale 3 \
--compute-scale 2 \
--ceph-storage-scale 0 \
--neutron-disable-tunneling \
--neutron-network-type vlan \
--neutron-network-vlan-ranges tenantvlan:x:x \
--neutron-bridge-mappings datacentre:br-ex,tenantvlan:br-nic4 \
--rhel-reg --reg-method satellite --reg-sat-url <URL> --reg-org <ORG> --reg-activation-key <KEY> --reg-force \
--ntp-server x.x.x.x \
--timeout 180


/usr/share/openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml was modified to include the details for external ceph.
Comment 3 James Slagle 2016-02-05 12:07:15 EST
please provide full output of the failed deployment using heat deployment-show

please provide the modified environment files.
Comment 4 Giulio Fidente 2016-02-05 18:26:21 EST
This is a regression introduced by https://review.openstack.org/#/c/263397/
Comment 5 Giulio Fidente 2016-02-05 18:44:08 EST
The change I point to in comment #4 shouldn't cause issues with the stock templates and environment files.

Is it possible you are passing:

  ControllerEnableCephStorage: true

in one of the custom environment files?
Comment 6 Giulio Fidente 2016-02-05 19:11:54 EST
Comment #4 and #5 are wrong. Attaching patches.
Comment 9 Udi Shkalim 2016-02-08 10:14:15 EST
Worked for me on 7.3 openstack-tripleo-heat-templates-0.8.6-112.el7ost.noarch
with the following command:
openstack overcloud deploy --templates -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation-v6.yaml -e /home/stack/network-environment.yaml -e puppet-ceph-external.yaml --control-scale 3 --compute-scale 3 --neutron-network-type vlan --neutron-tunnel-types vlan --neutron-network-vlan-ranges datacentre:204:215 --neutron-disable-tunneling --timeout 180 --ntp-server clock.redhat.com
Comment 10 Giulio Fidente 2016-02-08 10:24:43 EST
Udi, the bug was introduced in;

  openstack-tripleo-heat-templates-0.8.6-113.el7ost

and fixed in:

  openstack-tripleo-heat-templates-0.8.6-115.el7ost
Comment 13 Alexander Chuzhoy 2016-02-12 13:56:39 EST
FailedQA

Environment:
instack-undercloud-2.1.2-39.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-119.el7ost.noarch

Depoyment with external ceph failed:
Deployment command:
export THT=/usr/share/openstack-tripleo-heat-templates
openstack overcloud deploy --templates $THT \
-e /usr/share/openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/storage-environment.yaml \
-e /home/stack/network-environment.yaml \
-e /home/stack/ssl-heat-templates/environments/enable-tls.yaml \
-e /home/stack/ssl-heat-templates/environments/inject-trust-anchor.yaml \
--control-scale 3 \
--compute-scale 2 \
--ceph-storage-scale 0 \
--compute-flavor compute --control-flavor control --ceph-storage-flavor ceph-storage  \
--neutron-disable-tunneling \
--neutron-network-type vlan \
--neutron-network-vlan-ranges tenantvlan:18:43 \
--neutron-bridge-mappings datacentre:br-ex,tenantvlan:br-nic4 \
--ntp-server x.x.x.x \
--timeout 180


Error:


{ "status": "FAILED", "server_id": "637d0ab5-dec2-480e-9333-8d5f1f0076eb", "config_id": "8f640384-07a6-466c-9215-522dfa93d009", "output_values": { "deploy_stdout": "", "deploy_stderr": "Device \"br_nic2\" does not exist.
Device \"br_nic4\" does not exist.
Device \"ovs_system\" does not exist.
Warning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::host'; class ::nova::vncproxy has not been evaluated
Warning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::vncproxy_protocol'; class ::nova::vncproxy has not been evaluated
Warning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::port'; class ::nova::vncproxy has not been evaluated
Warning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::vncproxy_path'; class ::nova::vncproxy has not been evaluated
Error: Could not find data item ceph_mon_host in any Hiera data file and no default supplied at /var/lib/heat-config/heat-config-puppet/8f640384-07a6-466c-9215-522dfa93d009.pp:65 on node overcloud-compute-0.localdomain
Error: Could not find data item ceph_mon_host in any Hiera data file and no default supplied at /var/lib/heat-config/heat-config-puppet/8f640384-07a6-466c-9215-522dfa93d009.pp:65 on node overcloud-compute-0.localdomain
", "deploy_status_code": 1 }, "creation_time": "2016-02-12T18:44:15Z", "updated_time": "2016-02-12T18:44:50Z", "input_values": {}, "action": "CREATE", "status_reason": "deploy_status_code : Deployment exited with non-zero status code: 1", "id": "58490cc5-4e33-49af-b90f-6ebf8a5ec28a" }
Comment 19 Alexander Chuzhoy 2016-02-17 15:26:43 EST
Verified:

Environment:
openstack-tripleo-heat-templates-0.8.6-121.el7ost.noarch


Successfully deployed overcloud with externa ceph and verified the ability to create images, volumes,vms on the external ceph.
Comment 21 errata-xmlrpc 2016-02-18 11:52:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html

Note You need to log in before you can comment on or make changes to this bug.