Bug 1304838 - Only Default Organization shows up on 1B. Configure Organization of new deployment
Only Default Organization shows up on 1B. Configure Organization of new deplo...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
All All
medium Severity medium
: ga
: 1.0
Assigned To: jmagen@redhat.com
Tasos Papaioannou
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 13:27 EST by Tasos Papaioannou
Modified: 2016-09-13 12:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tasos Papaioannou 2016-02-04 13:27:06 EST
Description of problem:

I've created another organization on the RHCI server. It has discovered hosts, and I've linked the capsule, subnet, domain, environment, host group, and location records to it under Administer > Organizations. If I try to create new deployment, though, the 1B. Configure Organization tab shows only the Default Organization as available. Changing the context to the new org doesn't make any difference either.

Either the Configure Organization tab is broken, or there is some undocumented configuration required to get this to work.

Version-Release number of selected component (if applicable):

RHCI-6.0-RHEL-7-20160201.t.0

How reproducible:

100%

Steps to Reproduce:
1.) Create a new organization.
2.) Start a new deployment.

Actual results:

The new organization doesn't show up under 1B. Configure Organization.

Expected results:

The new organization should be visible and selectable.

Additional info:
Comment 1 John Matthews 2016-02-05 07:50:12 EST
Closing this BZ as we don't plan to support more than default organization in the installer.
Comment 2 Tasos Papaioannou 2016-02-06 10:14:26 EST
I'm reopening this BZ because I don't see this mentioned anywhere in the documentation. In fact, the Getting Started Guide includes creating an organization as a prerequisite. If there are no plans to support other organizations, then at the very least the documentation should reflect that.

---

https://access.redhat.com/documentation/en-US/Red_Hat_Cloud_Infrastructure/6/html-single/Getting_Started_with_the_Red_Hat_Cloud_Infrastructure_Unified_Installer/index.html#chap-Deploying_Red_Hat_Enterprise_Virtualization_and_Red_Hat_CloudForms

Prerequisites:

"Create an organization, which is a logical group for hosts, you want this deployment to belong to. A default organization is already created. For more information on creating organizations, see the Red Hat Satellite User Guide, Organizations for more information."

Procedure 3.1. Deploying Red Hat Enterprise Virtualization and Red Hat CloudForms:

Step 3b:

"Select an organization."

---
Comment 3 jmagen@redhat.com 2016-03-03 09:06:58 EST
Fixed. 
https://github.com/fusor/fusor/pull/699
Comment 5 Tasos Papaioannou 2016-06-23 10:04:48 EDT
Verified on QCI-1.2-RHEL-7-20160621.t.0.
Comment 11 errata-xmlrpc 2016-09-13 12:26:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.