Bug 1304869 - cups prints blank pages
cups prints blank pages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups-filters (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 15:45 EST by Jerry LeVan
Modified: 2016-03-30 16:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: cups-filters-1.8.3-1.fc24 cups-filters-1.8.3-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 15:33:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The trouble shooting report generated by system-config-printer (32.25 KB, text/plain)
2016-02-04 15:45 EST, Jerry LeVan
no flags Details
using the command 'lpr boatswain.pdf' (29.58 KB, text/plain)
2016-02-06 15:55 EST, Jerry LeVan
no flags Details
journalctl file for two step method (pdftops followed by printing the result (11.69 KB, text/plain)
2016-02-06 16:08 EST, Jerry LeVan
no flags Details

  None (edit)
Description Jerry LeVan 2016-02-04 15:45:08 EST
Created attachment 1121204 [details]
The trouble shooting report generated by system-config-printer

Description of problem:
I have an Apple LaserWriter 12/640 PS printer. It is configured as
a network printer with the Apple supplied ppd file.Attempting to print
a file using cups services ( printing from Firefox say ) results in
blank pages being printed. The print system goes through all of the motions
but only blank pages are emitted from the printer. I CAN print text files
using enscript or lpr.


Version-Release number of selected component (if applicable):
According to 'dnf' my system is up to date for everything.

How reproducible:
Every time

Steps to Reproduce:
1. Choose an app with a Print menu
2. Try to print a document
3.

Actual results:
Blank pages are emitted from the printer,

Expected results:
Actual print on the paper

Additional info:
I have a mac on the network and comparing the cups description with
the one on fedora shows that they are identical. Even the testpage
from system-config-print shows up as a blank page. ( The mac prints
correctly all of the time ). I am enclosing the computer generated
trouble shooting report.
Comment 1 Jerry LeVan 2016-02-05 17:26:14 EST
I configured another printer for the laser writer but used
the system supplied foomatic ppd for the 12/640 ps printer and
found that enscript would not work with the new ppd.

I have the same problem in a VirtualBox VM (Fedora 23 ) on one
of my macs..

something evil is happening...
Comment 2 Jerry LeVan 2016-02-06 15:55 EST
Created attachment 1121761 [details]
using the command 'lpr boatswain.pdf'

This is the results that appear in the journalctl file for user cups.
Everything looks ok to me but all I get is a single blank page.
Comment 3 Jerry LeVan 2016-02-06 16:08 EST
Created attachment 1121762 [details]
journalctl file for two step method (pdftops followed by printing the result

did
 pdf to ps using pdftops generating name.ps ( for instance )
 ps to printer using lpr -l <name.ps>
Comment 4 Jerry LeVan 2016-02-06 16:15:09 EST
grrr,

Comment 3 actually gives a primative workaround.

The boatswain.pdf file is three pages.

Converting the pdf directly vi pdftops to postscript
and then raw printing the file with lpr -l filename.ps
actually works...

Help me Rhonda, Help me...
Comment 5 Jerry LeVan 2016-02-09 11:14:25 EST
I can't get any useful results using the
'cupsfilter' function, probably because
I am not supplying a proper set of options
to the command...The man page is a bit opaque...

I was hoping to see if I could see where the
bad thing was happening.

Could some nice person tell me how
to use the 'cupsfilter' program to
mimic what is actually happening durning
the print process.

Jerry
Comment 6 Jerry LeVan 2016-02-12 17:29:26 EST
Rats,

Todays updates of the cups system cups-libs-1:2.1.3-1.fc23.x86_64, et al
did NOT fix my problem. I still only get a single blank page when
printing via CUPS. ie lpr boatswain.pdf  ( a three page pdf document )
only prints a single blank page.

Jerry
Comment 7 Jerry LeVan 2016-02-15 14:15:44 EST
It is starting to look like gs might be the bad guy...

I did a:  pdftops boatswain.pdf boatswain.ps

I turned the network attached Apple LaserWriter 12/640 off.

I did a:  lpr boatswain.pdf

When journalctl showed that cups could not contact the printer
I went to /var/spool/cups/tmp and copied the boatswain.ps over
the cupxxxx file in the tmp directory.

I then turned on the printer and after a bit the printer started
and the file was properly printed.

The spool file that was overwritten only prints a blank page.

Why does pdftops yield a ps file that prints fine on the LaserPrinter
but the ps file produced by CUPS fails to print?

I have noted that "gs -h" does NOT list the apple laserwriter 12/640 PS.

Help Me!
Comment 8 Jiri Popelka 2016-02-16 04:56:45 EST
(In reply to Jerry LeVan from comment #7)
> Why does pdftops yield a ps file that prints fine on the LaserPrinter
> but the ps file produced by CUPS fails to print?

There's a poppler's pdftops and cups-filters' pdftops filter, which adds some 'magic' on top of the poppler's. [1] might also help with debugging.

# rpm -qf /usr/bin/pdftops
poppler-utils-0.34.0-1.fc23.x86_64
# rpm -qf /usr/lib/cups/filter/pdftops
cups-filters-1.6.0-1.fc23.x86_64

[1] https://fedoraproject.org/wiki/How_to_debug_printing_problems#Running_filters_by_hand
Comment 9 Jerry LeVan 2016-02-21 13:40:31 EST
Sigh,

It seems to me that 'gs' is not producing postscript that the
Apple LaserWriter 12/240 PS can process...

If I stop the print queue and grab the spooled print file I CAN
view the file properly with both Evince and gs on the computer
screen.

journalctl following user cups shows no errors durinng the printing
process.

There is a 12/240 ps ppd file in the foomatic database but configuring
a printer with the foomatic system fails in the same way. ( only
a single blank page prints.)

The laserwriter does not print any error notices and I cannot
find anyway to have the printer tell me what the problem is...

Jerry
Comment 10 Jerry LeVan 2016-02-28 17:11:13 EST
Aha!

I sorta have pin-pointed what I believe is the problem.

I created a printer using an HP LaserJet 4 Postscript 600dpi
PPD during the create printer dialog.

Much to my surprise I WAS ABLE to print PDF files and jpegs!!!!

Examining the journalctl file for cups revealed the secret!

As the print job progressed the log showed (approximately) the
following:

   "Switching to Popplers pdftops instead of Ghostscript for old
   HP LaserJet....( some more nonvisable stuff)"

I had already (see above ) determined that the pdftops from poppler
produced postscript that prints on the LaserWrite 12/64 PS printer.

So...How can I convince cups that it should make the apple laserwriter 12/640ps
'old' so it will use pdftops instead of the Ghostscript software?

Help Me, Help Me!

Jerry
Comment 11 Jiri Popelka 2016-02-29 07:22:11 EST
Thank you for the investigation, reported upstream:
https://bugs.linuxfoundation.org/show_bug.cgi?id=1344
Comment 12 Jerry LeVan 2016-02-29 09:33:47 EST
Ok,

I have solved the problem with a workaround.

What is needed is a way to insert pdftops as the
renderer instead of gs.

1) The easy way:
    As root:  lpadmin -p laser -o pdftops-renderer-default=pdftops

2) As root 
    Stop cups: 'systemctl stop cups'
    Edit the file /etc/cups/printers.conf and add:
          Option pdftops-renderer pdftops 
     to the appropriate 'stanza"
     Start cups:  'systemctl start cups'

<DefaultPrinter laser>
UUID urn:uuid:6667b7d8-7ea8-3cc4-62e5-08c979df5c5b
Info Apple 12/640 Laser Printer
Location Computer Room
MakeModel Apple LaserWriter 12/640 PS v2015.105
DeviceURI lpd://192.168.1.40/raw
State Idle
StateTime 1456754226
ConfigTime 1456700980
Type 8392772
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
Option gamma 986
Option hue 10
Option outputorder reverse
Option page-bottom 20
Option page-left 20
Option page-right 20
Option page-top 20
Option pdftops-renderer pdftops  <---- add this line
Option print-quality 3
Option saturation 88
</DefaultPrinter>

This also fixes the identical problem with the foomatic 
apple 12/640ps print driver. 

gs probably does some level 3 ps stuff that screws with level 2 printers.

Hey my Apple LaserWriter 12/640PS might be 19~20 years old but it
still prints well enough for me.

Jerry
Comment 13 Jiri Popelka 2016-02-29 10:34:22 EST
Should be fixed upstream
http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7449
Comment 14 Fedora Update System 2016-03-24 11:42:27 EDT
cups-filters-1.8.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2c633b23dc
Comment 15 Fedora Update System 2016-03-24 11:42:35 EDT
cups-filters-1.8.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9dd9d69009
Comment 16 Fedora Update System 2016-03-25 16:28:02 EDT
cups-filters-1.8.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9dd9d69009
Comment 17 Fedora Update System 2016-03-26 11:20:03 EDT
cups-filters-1.8.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2c633b23dc
Comment 18 Fedora Update System 2016-03-29 15:33:08 EDT
cups-filters-1.8.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2016-03-30 16:51:18 EDT
cups-filters-1.8.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.