This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 130488 - Bluetooth dongle doesn't pair
Bluetooth dongle doesn't pair
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-20 15:22 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 05:15:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-08-20 15:22:17 EDT
Description of problem:

  I have a D-Link DBT-120 dongle plugged into a random USB socket.
When I open Gnome-System Tools->Bluetooth Manager (which opens its
window 'behind' this Mozilla window..), Then (bring BTM window
forward) select Devices->Scan. The BTM says Scanning for devices..

Then I click around on my Sony Ericsson T68i to get it's Bluetooth in
'Discoverable Mode'.

The phone is flashing its blue light periodically, the DBT-120 dongle
power light is on.

  No 'found' happens in the Bluetooth Manager window.

Version-Release number of selected component (if applicable):

  System is up2date as of a few minutes ago.

  BTM says Copyright Bill Dumbill 2003 in its 'About' box.

How reproducible:

  I have been checking BTM for awhile now - months. Has never worked.

Steps to Reproduce:
1.  as detailed above
2.
3.
  
Actual results:

  zit

Expected results:

  Some friendly greeting saying that it has discovered my phone and
asking whether I want to 'pair up' with it.

Additional info:

[user1@hoho2 ~]$ cat /proc/version
Linux version 2.6.8-1.524smp (bhcompile@tweety.build.redhat.com) (gcc
version 3.4.1 20040815 (Red Hat 3.4.1-8)) #1 SMP Wed Aug 18 12:12:51
EDT 2004
[user1@hoho2 ~]$
Comment 1 Harald Hoyer 2004-08-31 07:39:52 EDT
1. be sure service bluetooth is on. as root do:
  # chkconfig --add bluetooth
  # chkconfig bluetooth on
  # service bluetooth start

2. as root scan for BT devices manually:
  # hcitool scan

if it does not find your cellphone, well then maybe your BT driver is
not working...
Comment 2 Bob Gustafson 2004-08-31 16:21:54 EDT
[root@hoho2 ~]# /sbin/chkconfig --add bluetooth
[root@hoho2 ~]# /sbin/chkconfig bluetooth on
[root@hoho2 ~]# /sbin/service bluetooth start
Starting Bluetooth services:                               [  OK  ]
[root@hoho2 ~]# hcitool scan
Scanning ...
[root@hoho2 ~]# hcitool scan
Scanning ...
        00:0A:D9:1E:7C:EB       T68i-bg
[root@hoho2 ~]#

Cool - what should I do next
Comment 3 Harald Hoyer 2004-09-01 05:06:39 EDT
now you can try the BTM to find your cellphone...
Comment 4 Bob Gustafson 2004-09-03 02:11:46 EDT
OK, did:

[root@hoho2 ~]# /sbin/chkconfig --add bluetooth
[root@hoho2 ~]# /sbin/chkconfig bluetooth on
[root@hoho2 ~]# /sbin/service bluetooth start
Starting Bluetooth services:                               [  OK  ]
[root@hoho2 ~]#

Then I got out phone, fired up BTM, turned on phone 'discoverable'.

THen selected SCAN from BTM menu

BTM dialog box at the very bottom (in frame of window) said that it
had found device and gave the ID number.

Then after 10 seconds or so, the message at the bottom said 'Scanning
complete".

However, nothing came in the BTM window itself. No query for password,
no pairing request.

What should I do next.

(Note - I am trying to keep up2date as much as possible - modules/apps
change. Maybe these features are in the next version of BTM?)
Comment 5 Harald Hoyer 2004-09-03 04:34:52 EDT
hmm, works for me... 
after the first scanning, nothing was displayed to me, too. but in
further sessions it worked.
try sending a file to your phone...
Comment 6 Bob Gustafson 2004-09-03 10:36:21 EDT
I think I am close.

I opened the BTM (have not rebooted since installing bt modules from
last time)

Then Phone->BT->Linked devices->Add device->Phone initiates->Computer

Phone said "Prepare Computer".  I clicked on Gnome->BTM->SCAN.

After about 6-7 seconds, I saw "Device Found' on phone, with the name
of my computer shown.

I selected and 'clicked' on that line on my phone screen and I got the
message "Add to paired" and "Password". I put in an easily remembered
password and the phone came back "Pairing Failed, Retry?"

During this time, there was no dialog shown on the white part of the
BTM window.  At the bottom on the frame, there was something that
looked like a progress bar - half way. And the message "Retrieving
device names.."

No password request, no text on screen white part.

When did you put in your computer's password?
Comment 7 Harald Hoyer 2004-09-03 10:48:40 EDT
you should set a pin in /etc/bluetooth/pin
Comment 8 Bob Gustafson 2004-09-03 10:58:48 EDT
I think I will follow the procedure in:

  http://home.tiscali.be/philipa/p900.html#btsetup

Will report back in a couple of hours.

Thanks much.
Comment 9 Bob Gustafson 2004-09-03 11:37:26 EDT
OK - One wrinkle is that my phone puts asterisks in the display. Also,
the phone keypad is overloaded. One press can do letters, a number,
etc. Without a clear display - difficult to put in a matching pin, so
I gave up on UppperLower case - in fact gave up on letters.

It seems like there is some sort of pin state in the BTM, so I gave a
HUP to the hcid in 'ps ax' and restarted BTM.

I went to the phone and did as before, being careful to put on the
password as unambiguously as possible.

Bingo, pairing succeeded.

And I have an icon in the BTM window. It even has the right name.

But, it does not have any properties!

Will continue following tiscali instructions.
Comment 10 Bob Gustafson 2004-09-27 12:27:30 EDT
OK, paired.

Will continue (I am not working on this full time.. :-)

Note You need to log in before you can comment on or make changes to this bug.