Bug 1304880 - atomic-openshift-master.service on Native HA installs needs to be removed.
atomic-openshift-master.service on Native HA installs needs to be removed.
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 16:41 EST by Ryan Howe
Modified: 2016-07-03 20:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: atomic-openshift-utils-3.0.39-1.git.0.226c87d.el7aos.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 07:57:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2016-02-04 16:41:45 EST
Description of problem:
On native ha installs atomic-openshift-master.service needs to be removed. 

$ rm /usr/lib/systemd/system/atomic-openshift-master.service

To many users are starting this service expecting it to be running. If this service is running then the api and controllers will not start. 


Version-Release number of selected component (if applicable):
3.1.x

How reproducible:
100%

Steps to Reproduce:
1. run the following on all masters $ systemctl stop atomic-openshift-master-controllers 
2. run the following on all masters $ systemctl stop atomic-openshift-master-api
3. then start atomic-openshift-master  and then api and controllers

Actual results:
Failures on the api and controllers. 

Expected results:
For atomic-openshift-master.service to kick off the api and controllers instead of a single master process. Or for this service to be removed. 


Additional info:

Suggested change: 


Change the service to start both api and controllers:

$cat /usr/lib/systemd/system/atomic-openshift-master.service

[Unit]
Description=Atomic OpenShift Master
Documentation=https://github.com/openshift/origin
Requires=atomic-openshift-master-api.service
Requires=atomic-openshift-master-controllers.service

[Service]
Type=simple
ExecStart=/usr/bin/echo "Starting atomic-openshift-master-api.service and atomic-openshift-master-controllers.service"

[Install]
WantedBy=multi-user.target
Comment 1 Jason DeTiberus 2016-02-04 17:34:01 EST
We can't really remove it since it is tracked by the RPM package and any update would replace it.

What we could do though is to mask the service to make it difficult for them to start it up unintentionally.

That does make me wonder whether we could use an override unit to make it basically do nothing but kick off both the api and controllers services instead though... We could basically drop a replacement unit into /etc/systemd/system and it could override the behavior of the default shipped unit.
Comment 2 Jason DeTiberus 2016-02-05 09:53:18 EST
I've created the following PR to mask the service: https://github.com/openshift/openshift-ansible/pull/1342

While we could try to create a unit to control both, I suspect we'll hit edge cases where it doesn't behave properly. For example, the suggested changes you've proposed would work for start, but would not work for stop/restart.
Comment 5 Ma xiaoqiang 2016-02-13 21:31:40 EST
Check on atomic-openshift-utils-3.0.40-1.git.22.da21865.el7aos.noarch

Install native-ha env. Check the atomic-openshift-master service

# service atomic-openshift-master restart
Redirecting to /bin/systemctl restart  atomic-openshift-master.service
Failed to restart atomic-openshift-master.service: Unit atomic-openshift-master.service is masked.

Move this issue to VERIFIED.
Comment 7 errata-xmlrpc 2016-02-29 07:57:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0311

Note You need to log in before you can comment on or make changes to this bug.